Audi Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello,

None know how I can delete secret code in electronics controls modules ( i mean which one for tempomat, steering wheel and so on...), it looks as you call SCR ( sorry if i made mistake )

I can't insert new code in module, I do as vag coding helper suggest me...then.." Do it!" and code come back in the original form. So I think my controller got a secret code to insert inside...

I got an A3 8p 2006

Is there anyone which could help me..please?
My dealer said i got 8p0 953 549 E, with Vag Sw and cables I see as code 1K0 953 549 AF

Thanks
 

·
Premium Member
Joined
·
11,350 Posts
Maybe you are trying to enter a coding value that the SCSM version you have cannot accept?

What is the coding value now?, and what do you want to change it to (and why?)?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Hi,

I changed electronic modules because I thought new multifunction steering wheel not worked, so now...I'm trying to set new modules.

A part of some little problems, during normal setup ( hoping to be able to resolve...I'm praying...), I can't set anyone code in this case, because new modules not let's me insert workshop code.

It looks as it could change....do you know if I can change..? I need to set because I need to let's read multifunction, bluetooth and so on...

If you care and if you need I can copy errors from Vag Sw...

Thanks
 

·
Premium Member
Joined
·
11,350 Posts
The module part number, it's current code and the changes you are trying to make would help me make some suggestions.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Just installed Module Parts: 8P0 953 549 F to be able to install a multifunction steering wheel.
None hope to change code for module parts, because vag said Workshop code is wrong ( I don't know as I can change )
New part see Steering Wheel with tiptronic + computer board and cruise control. I've none tiptronic and none cruise control.

Error on the Instruments:
- Abs Light
- Steering Wheel Light

Error Vag
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Address 16: Steering wheel
Part No: 8P0 953 549 F
Component: J0527 H34 0070
Coding: 0014142
Shop #: WSC 131071

Part No: XXX XXX XXX XX
Component: E0221 H07 0080

1 Fault Found:
00895 - Cruise Control Switch (E45)
014 - Defective


--------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Address 44: Steering Assist
Part No: 1K1 909 144 J
Component: EPS_ZFLS Kl.5 D04 1606

2 Faults Found:
02546 - Steering Limit Stop

005 - No or Incorrect Basic Setting / Adaptation
00778 - Steering Angle Sensor (G85)
005 - No or Incorrect Basic Setting / Adaptation

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Gateway Installation List: 1K0 907 530 F

01-Engine -- Status: OK 0000
03-ABS Brakes -- Status: Malfunction 0010
00-Steering Angle Sensor -- Status: OK 0000
15-Airbags -- Status: OK 0000
44-Steering Assist -- Status: Malfunction 0010
09-Cent. Elect. -- Status: OK 0000
46-Central Conv. -- Status: OK 0000
42-Door Elect, Driver -- Status: OK 0000
52-Door Elect, Pass. -- Status: OK 0000
16-Steering wheel -- Status: Malfunction 0010
08-Auto HVAC -- Status: OK 0000
7D-Aux. Heat -- Status: OK 0000
47-Sound System -- Status: OK 0000
37-Navigation -- Status: Not registered 0011
56-Radio -- Status: Malfunction 0010
77-Telephone -- Status: Not registered 0001
17-Instruments -- Status: OK 0000
25-Immobilizer -- Status: OK 0000
19-CAN Gateway -- Status: Malfunction 0010

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------

That's all...hoping someone can help

I need to try some idea which a good guy suggest me...and I hope everything will be ok

Thanks
 

·
Premium Member
Joined
·
11,350 Posts
The ABS light (and probably the steering whell light too) is on because of the G85 sensor error.

The Ross Tech website tells how to clear the G85 error - it's really easy and takes maybe 30 seconds or less.

The E45 error means that you have coded the SCSM to look for a cruise control switch and their either is't one connected or the one that is connected is faulty.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
PetrolDave said:
The ABS light (and probably the steering whell light too) is on because of the G85 sensor error.

The Ross Tech website tells how to clear the G85 error - it's really easy and takes maybe 30 seconds or less.
Yes, Ive done

The E45 error means that you have coded the SCSM to look for a cruise control switch and their either is't one connected or the one that is connected is faulty.
In this case...I don't know what I can do...it doesn't permit me to recode because it said workshop code is wrong...but I can't modify...

Thanks
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
All done

Last error:

Sunday,14,May,2006,13:09:11
VAG-COM Version: Release 512.4-UD

Gateway Installation List: 1K0 907 530 F

44-Steering Assist -- Status: Malfunction 0010

16-Steering wheel -- Status: Malfunction 0010

37-Navigation -- Status: Not registered 0011

56-Radio -- Status: Malfunction 0010

77-Telephone -- Status: Not registered 0001

19-CAN Gateway -- Status: Malfunction 0010

And...

Address 19: CAN Gateway
Part No: 1K0 907 530 F
Component: Gateway H10 0120
Coding: 3D0F0B42070100
Shop #: WSC 06314

1 Fault Found:
01044 - Control Module Incorrectly Coded
000 - -


That's all....but I don't know as I can set Gateway because of I need Long coding to set and let's see Gateway the Navi, Telephone and so on...
 

·
Premium Member
Joined
·
11,350 Posts
VAG-COM 512-4 includes a Long Coding Helper.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #10 ·
PetrolDave said:
VAG-COM 512-4 includes a Long Coding Helper.
yes, it's true. however it doesn't permit me to change options for navi or bluetooth...

You need to insert a valid Byte to codify the right signal...and without long coding helper I've had to study...correct mode

Thanks
 

·
Registered
Joined
·
83 Posts
Bluesun wrote (a long time ago):

"In this case...I don't know what I can do...it doesn't permit me to recode because it said workshop code is wrong...but I can't modify... "

If anyone is experiencing the same problem a solution that has helped me earlier on is to change your workshop code under "settings". This is typically "0000" to avoid changing the original workshopcodes in your modules - this is also why you can't change a "faulty" workshopcode (ie a 6-digits long code). If you type somethin else than "00000" in your VagCom setting, you'll be able to change the faulty workshopcode. If you afterwards delete your vagcom.cfg a new one is created and you'll be able to set your workshopcode to "00000" again.

I had the same problem with a cruisecontrol (GRA) and it did the trick for me.

Regards

Per
 
1 - 11 of 11 Posts
Top