Audi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all! A bit stumped here. Did the RNSE retrofit into my B5 S4 and got everything working great. I followed the excellent write up by Teddy and got everything situated. drove it for a few days and had no issues. I did not get the unit with NA maps so I ordered some off ebay. I got the 2015/16 maps. When i inserted the discs, got no loading screen or anything. Maps just appeared and seemed to work after I entered my location. Now here is the strange part, After two days of it working fine, my car will not accept the pin while car is on in acc mode or engine on, it will just loop back to pin screen. I know absolutely that its the right pin because it accepted it after initial install and its on the unit. Now IF I turn the unit on without key in acc mode or engine on, the unit works! Will accept pin and maps will come on/show my location. I go into version and Im SW: 270 HW:75 and it recognizes the nav disc. Used VCDS to look for codes and found short to ground for antenna. Codes will clear then come right back after a key cycle. Scanned instrument cluster for codes and got 4 codes:
01300 Control module for nav with cd-rom J401
01304 Radio 49-10 No communication- Intermittent
01311 Information Data Bus 37-10 Faulty-Intermittent
01311 Intermittent Data Bus 80-00 Single wire Operation

I checked my pins for Can H/L and they are good, lights will come on and screen will dim when i turn my headlights on. Cleared those 4 codes for instruments and only the Intermittent Data bus single wire code persists. Radio codes that return are just short to ground for radio antenna.

Am I looking too far into this or is it simply that I need to replace the two wore antenna adapter (diversity and other one)

Appreciate any help!
 

·
Registered
Joined
·
12 Posts
Sounds like this is all down the CANBUS issues. The unit uses the VIN which is transmitted over CAN to decide if it is in the same vehicle or not as when the PIN was last successfully entered, and if it is then it bypasses the PIN entry.

When you have an intermittent CAN some things can work, for example simple things like light status where there is a single CAN message repeated multiple times every few hundred milliseconds, and other things like VIN number which requires 3 consecutive successful packets to send an entire VIN number can fail.

I know this because I spent many hours scratching my head with my own unit that was working 100 reliably on an install, but then stopped responding to certain signals from the car after I did some wiring rework for the reversing camera and adding an adapter onto CAN. Eventually I discovered one of the CANBUS wires was broken in the quad lock wiring adapter.

Didn’t help I was also trying out a experimental version of the firmware at the time. Threw a whole load of spanners in the fault finding exercise that one...

BTW: Shameless plug...
Here’s my firmware update site for anyone with an RNS-E with a whole load of fixes and enhancements for your units. For those of you with NA region units my latest beta release also includes reintroduction of TV support, for both the 192 and 193.
Enjoy.
 

·
Registered
Joined
·
362 Posts
BTW: Shameless plug...
Here’s my firmware update site for anyone with an RNS-E with a whole load of fixes and enhancements for your units. For those of you with NA region units my latest beta release also includes reintroduction of TV support, for both the 192 and 193.
Enjoy.
I wondered how you were getting along with your firmware updates. Nice work. Now you just need to buy a car with MMI 3g...😎
 
1 - 5 of 5 Posts
Top