Audi Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Friends, I've searched on this forum including posts by rabbit, PetrolDave, etc

Here's the situation. My car is 2005 B7 A4, RNS-E had software version 500 IIRC.

1) as I'm in Singapore which has no support for NAV DVD by Audi, all RNS-E units are aftermarket installations. I bought mine from someone who bought it from eBay but never installed it. It was sent to Europe for unlocking of VIM by the previous owner.

2) After installation of bluetooth, RNS-E, everything worked with MFSW functions, etc. Intermittently there the unit would hang and freeze even with ignition off, but removing battery would solve the problem.

3) Now the RNS-E is showing this, it suddenly happened one day:


4) Removing the battery does not work, after re-connection the unit shows the same display.

5) There is no read-out via VAG-COM, which was possible before. The unit completely does not respond to any combination of button pushing.

6) Screen opens and closes, no problem. But I have no original DVD to try to fix this.

Somebody, please help me. Thank you very much!
 

·
Super Moderator
Joined
·
11,350 Posts
I think there may have been one previous post on this issue which suggested that the proble is that your flash memory has been corrupted or failed.

It may be worth buying a 2008/2009/2010 EU map DVD (it doesn't matter if it's DVD1 or DVD2 since you can't use the maps) from eBay and seeing if inserting one of them will cause the SW to be re-programmed.

Not sure if this would work but if you can find a map DVD cheap enough on eBay it could be worth trying?
 

·
Registered
Joined
·
115 Posts
Hi,
PetrolDave is right, try to put the Original DVD, do the reset (40 seconds, press the volume knob) and wait. If this does not help, it can be programmed using a flash memory programmer.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thanks PetrolDave! Is it confirmed that I should get an EU DVD? Would a DVD from any other country help?

kobra7, how do I go about using a flash memory programmer to solve the issue? Thanks a lot.
 

·
Registered
Joined
·
115 Posts
Thanks PetrolDave! Is it confirmed that I should get an EU DVD? Would a DVD from any other country help?

kobra7, how do I go about using a flash memory programmer to solve the issue? Thanks a lot.
You need to find an electronic workshop, which has a programmer and adapter for flash memory - 29XL12DF. (I have such equipment)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
I just wanna thank PetrolDave and Kobra, you guys solved the problem for me! I am so happy you guys rock!

For those who ever have the same problem, here's what I did:

- downloaded the software free (since I couldn't use the maps anyway). It took me 4 days over wireless with my laptop turned on 24 hrs.
Audi A3/A4/A6/TT Western Europe DVD1 2009 (RNS-E) (download torrent) - TPB

- "burned disc image" onto a DUAL LAYER DVD-ROM. My laptop can write to "DVD-R DL" discs and this is exactly what the RNS-E requires. The image is 7.7GB so a standard DVD will not have sufficient space. Remember to "burn" the image and not copy the files onto the disc. I wasted one disc doing that.

- inserted the DVD into the RNS-E and it automatically updated the software. No issues now, it is 100% back to normal. My MFSW and bluetooth work beautifully, and all my previous settings were retained as well.

I'm in love with my RNS-E all over again!!!!!
 

·
Registered
Joined
·
1 Posts
Friends, I've searched on this forum including posts by rabbit, PetrolDave, etc

Here's the situation. My car is 2005 B7 A4, RNS-E had software version 500 IIRC.

1) as I'm in Singapore which has no support for NAV DVD by Audi, all RNS-E units are aftermarket installations. I bought mine from someone who bought it from eBay but never installed it. It was sent to Europe for unlocking of VIM by the previous owner.

2) After installation of bluetooth, RNS-E, everything worked with MFSW functions, etc. Intermittently there the unit would hang and freeze even with ignition off, but removing battery would solve the problem.

3) Now the RNS-E is showing this, it suddenly happened one day:


4) Removing the battery does not work, after re-connection the unit shows the same display.

5) There is no read-out via VAG-COM, which was possible before. The unit completely does not respond to any combination of button pushing.

6) Screen opens and closes, no problem. But I have no original DVD to try to fix this.

Somebody, please help me. Thank you very much!
plz help cd rom set orignal
 
1 - 7 of 7 Posts
Top