Audi Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
hey guys,

i just bought an new rns-e from ebay and i think the radio function isnt working properly... if i search for stations every station is found and i can also listen to them.... i can even save them but when i look at my saved stations all the stations are grey so i cant select them and only 1-2 are orange...

if i click again on memory to see ALL available stations its only showing up very strange letters like Üö% and other strange things...

whats wrong with my unit what should i do? Its an 2006 A4 unit but with the 0080 european software installed.
 

·
Registered
Joined
·
6,767 Posts
Strange characters are usually a sign for an incomplete software update. Are you in Europe or the US? And do you have a newer DVD?
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #3 ·
im in europe germany... i inserted the 2004 0080 dvd and a software update started.. i think the 0050 software was installed before.. but nothing changed after that update... still strange characters and radio stations are not safed.. i will make some photos now so you guys can see what i mean.

Do you think this is caused by an bad eprom? Another strange thing i noticed was that the unit was never asking for any code... i even disconnected the unit for 10 minutes, tryed it many times again but it never asks for any code...



 

·
Premium Member
Joined
·
11,350 Posts
a4cab said:
Its an 2006 A4 unit but with the 0080 european software installed.
Hmmmm. If it really is a 2006 A4 unit then I would expect it to have SW much later than 0050 or 0080 - probably 0330 or later.

Makes me suspicious that the unit is not what you expect.

Where did you get the unit from?
 

·
Registered
Joined
·
6,767 Posts
I have seen units that were running the navi sw form a 0050 or 0080 DVD but the audio sw from a 0330 or higher DVD. That won't work and result in issue as you see here.

If you have a VAG-COM, remove the DVD, change channel 97 in #37 to 1 and reinster the DVD. The RNS-E should start an update process and reboot twice. During that process it should update the navi and audio sw and the issue shuld go away.

The better option is to get a 2006 DVD and use that to update both navi sw and audio sw to the newest version (the audio sw on 2006 and 2006_1 are the same). This should also solve the problem.

besides that I agree with PetrolDave, a trustworthy seller would help you to fix this problem or wouldn't have sold you such a unit in the first place.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #6 ·
the unit had the latest software installed which was 0500 from the 2006_1 DVD but i did the VAG-COM downgrade trick to downgrade to my 0080 software cause i thought the old nav disc wouldnt work in this unit with the new software...

i have already bought an 2006_1 disc and im just waiting to receive it then i will test if that helps... if it doesnt what do you guys suggest then? Do you think the eprom could be broken?
 

·
Registered
Joined
·
6,767 Posts
Just try the update first and let it reboot twice. I don't think the hardware is broken.
 

·
Registered
Joined
·
5,817 Posts
mostlikely Radio sector in your upgrade file is corrupted.
In worst case scenario you will need to reverse Firmware and load it again.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #9 ·
first the unit had software 0500 installed then i downgraded it to 050 using the vag-com downgrading trick... then i saw the strange letters and the problem with the radio stations.... so i upgraded to 080 but that didnt help... if its a firmware problem then why wasnt that fixed when i upgraded to 080??

And why am i not able to select my saved radio stations? They all appear grey and not orange? I cant select them... when i use the tuner and select the radio stations manual then it works fine and i can listen to all stations without problems...
 

·
Registered
Joined
·
6,767 Posts
Forget the stored stations for the moment. What media did you use to downgrade to 0050 and upggrade to 0080? Do you have DVDs with both software versions? If you do, try to downgrade again using the 0050 CD/DVD. Wait until the RNS-E has rebooted twice, the first time it updates the navi software and the second time it updates the audio (radio) software. Once you got it downgraded insert the 0080 CD/DVD and let it upgrade, again the RNS-E must reboot twice to complete both updates.

To confirm the versions currently running on your RNS-E, go into Engineering Mode and look up the NAVVER and AUDVER. Post the versions and we wil be able to tell you if you are having a version mismatch right now. I fyou do, that 99% the reason for your radio issue.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #11 ·
here are the informations:

Navi SW Version: V220028C
Audio SW Version: A2210134-280705
Boot Version: V220100D

Is everything ok with these details? What should i do now?
 

·
Registered
Joined
·
6,767 Posts
V220028C is from the Euro 0080 software, A2210134 is from the Euro 0450 software, so you definitely have a version mismatch there.

You said you have the Euro 0050 (2004) DVD. Try to set channel 97 in STG #56 to 1, save the value and insert the DVD. You RNS-E should do a downgrade and reboot twice. Wait for both reboots to complete. At that point you radio should be fine again. Change the value in 97 back to 0 and wait for the 2006 DVD to arrive. Once you got the 2006 DVD, insert the DVD and wait again until both reboots have happened. Check the version numbers after you are done, they should match the numbers liste din Index.txt on the DVD.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #13 ·
i just did the downgrade to 050 but the audio sw version is still the same... what should i do now?

the versions are now:

Navi sw version v220100d
Audio SW version A2210134-280705
Boot version V220100D
 

·
Registered
Joined
·
6,767 Posts
What is the contents of the index.tx on the DVD you are using to downgrade? What is the name of the MOT file on that DVD?
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #15 ·
contents of the index file are:

SOFIDX:0050
NAVVER:V220026F
AUDVER:A2200066


name of the mot file is: A2200066.MOT
 

·
Registered
Joined
·
6,767 Posts
ANy chance that you can get a newer DVD? A 2006 or 2006_1 for example? When you did the downgrade, did you RNS-E reboot twice or did you remove the DVD / change the channel value after the first reboot?
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #18 ·
i have already orderered the 2006_1 dvd i should have it in about 2 days.

the unit didnt reboot twice it did just reboot one time then i removed the dvd again and i didnt change the vag-com value back again... i thought this would change back again by it self.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top