Audi Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
sorry if this has been covered but i could only find one post post on the subject and it didn't answer my question.

retrofit rns-e in a3 2006 stays on until i turn it off, this has obviously become rather annoying, on my old alpine unit it was a matter of switching the red and the yellow cable around in the harness. could anyone help me which which pins i have to swap around either at the car end or the rns-e end of the harness.

i'm so close to getting this functioning as i intended but something else keeps cropping up.
 

·
Registered
Joined
·
6,767 Posts
It should turn off when you turn off ignition (US) or remove the ignition key (RoW). If it doesn't then it's eithe rnot coded for an A3 or the CAN wires are not connected properly. What about the buttons? Do they light up when you turn on the lights?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
its a european car / rns-e is european, unit has to be switched off when leaving vehicle or it will keep on running, so it is off when i start igintion i have to turn it on, buttons light up. kufatec supplied harness, i haven't vagcommed yet, is this the reason?
 

·
Registered
Joined
·
1,624 Posts
If you have not recoded with VAG then your installation is not complete. Please report back after the work is finished.
 

·
Registered
Joined
·
6,767 Posts
In Europe the RNS-E will turn off as son as you remove the ignition key. When not powered off manually it will turn on as soon as you turn on the ignition. If it doesn't, incorrect coding might be the reason.
 

·
Premium Member
Joined
·
11,350 Posts
If you have not coded the unit yet with VAG-COM it is very possible that the unit does not understand the commands it receives on the CAN bus that tell it when to turn on and off (and when to illuminate its buttons).

Code the unit correctly and reset and re-check the fault codes with VAG-COM, and then tell us what is happening.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Thanks, i've ordered a VAG-COM lead from Ross Tech should arrive some time this week. will report back the outcome.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Problem Solved Thanks

Problem solved, RNS-E now switches off with ignition. I've just got my VAG-COM cable from Ross-Tech. i bought a Micro-CAN cable, a cheaper version of VAG-COM works with any VAG car based on the MK5 Golf, I have an Audi A3 8P. I have quite a few faults which i have no clue how to deal with. The coding however was quite straight forward thanks to http://oooo-a3.blogspot.com/. The Harness seemed to be correct from Kufatec. Off to work out these code faults.
 

·
Registered
Joined
·
7 Posts
This is just to warn anyboby who intends to shop at www.kufatec.de, especially for international shipments.
I'm currently having a case since more than 2 months now where I have paid everything in advance and never received their parcel which happened to be lost by the carrier. I have provided them with all the proof of non receipt they have requested, and it is now 6 weeks that they keep telling me that they are waiting for detailed delivery report from the carrier. Every time I call them, they confirm that my parts have been newly shipped but nothing has arrived yet.
This people are just not serious and I can only recommend you not to try it.

Just have a look at that thread :
http://www.navplus.us/forum/viewtopic.php?highlight=kufatec&t=503
 

·
Registered
Joined
·
41 Posts
rodo said:
retrofit rns-e in a3 2006 stays on until i turn it off
NSX JR said:
If you have not recoded with VAG then your installation is not complete
Soooo, if I didn't like the "RNS-E Off w/ Ignition" thing and was okay with manually shutting it off when I exit the car, then I could tweak it to where this is possible?
 

·
Premium Member
Joined
·
11,350 Posts
abdrury said:
rodo said:
retrofit rns-e in a3 2006 stays on until i turn it off
NSX JR said:
If you have not recoded with VAG then your installation is not complete
Soooo, if I didn't like the "RNS-E Off w/ Ignition" thing and was okay with manually shutting it off when I exit the car, then I could tweak it to where this is possible?
You could fit a CANgate (from bjarne) that modifies the CAN bus messages to change the behaviour of US units to the same as European units - i.e. they switch off when you remove the key not when you turn off the ignition.
 

·
Registered
Joined
·
41 Posts
Yes, I remember coming across that information a while back. If I were too cheap to buy that, though, could I do some VAGCOM coding to make it not turn off unless I manually shut it off? I would be imitating the fault that the original poster was having, but it would at least allow the unit to remain on until I leave the car. . . .
 

·
Premium Member
Joined
·
11,350 Posts
abdrury said:
Yes, I remember coming across that information a while back. If I were too cheap to buy that, though, could I do some VAGCOM coding to make it not turn off unless I manually shut it off? I would be imitating the fault that the original poster was having, but it would at least allow the unit to remain on until I leave the car. . . .
There's no separate coding for the on/off behaviour. The problem that rodo was having was because his RNS-E was coded for a different model Audi.

You could deliberately change the coding to a different model, but it would also mean the button illumination probably wouldn't work (and the maps would be bright at night instead of dimming) and the speed signal probably wouldn't be received by the RNS-E so your navigation would be jerky and inaccurate.

I would suggest you live with the ignition off behaviour, or if that really annoys you get a CANgate.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top