Audi Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I recently installed the RNS-E unit into my 06 A4. The CD/DVD ejection and loading will not work. My CD is stuck inside the navigation unit. It was making weird sounds when trying to read the CD. Please help!
 

·
Registered
Joined
·
5,817 Posts
Sounds like your drive is damaged. It is either right loading bracket or one of the sliding triggers from the front. RNS-E drives include plastic parts so if one of those broke you would be out of luck.

Where you bought your unit?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
PROXUS said:
Sounds like your drive is damaged. It is either right loading bracket or one of the sliding triggers from the front. RNS-E drives include plastic parts so if one of those broke you would be out of luck.

Where you bought your unit?
Great. bought it online. I opened it up and sure enough, there was a plastic part that feel out. I am so MAD right now.
 

·
Registered
Joined
·
5,817 Posts
Sorry to hear that. Buying stuff like that online is usually like playing Russian roulette, especially that a lot of sellers with low prices don't care about any service or just trying to get rid of their damaged units.

I can only suspect that your plastic part was broken and glued before, because it would be really hard to brake it during normal use of the unit.
(I'am assuming you didn't push it too hard)

The only option is to find replacement drive (which is almost impossible) or try to fix it somehow.
 
1 - 6 of 6 Posts
Top