Audi Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Hello,

I have upgraded my rns-e software to sw 0450. After the upgrade i tried to recode the head unit using Vag-com 409 and a third party cable but what ever number in put in the coding it returns back to the one previously coded. It is stuck!. the workshop number is also hidden now i connot enter a number in its brackets!!
What is the problem?
 

·
Registered
Joined
·
6,767 Posts
Without know what coding you tried to safe I would say a) the VAG-COM version and b) the 3rd party cable.
 

·
Registered
Joined
·
6,767 Posts
This is not a valid coding. xxxxx4x should be xxxxx1x if you are in Europe of xxxxx3x if you are in the US.
 

·
Premium Member
Joined
·
11,350 Posts
topgun9014 said:
i am trying to code 0403347
Let's break down that coding:

4 = A4 cabrio
0 = front speaker diagnostics on
3 = A4 cabrio, non-Bose
3= Cullman phone
4 = satellite & digital radio
7 = CD changer & MFSW

First things first, do you have an A4 cabrio without Bose? If you do then the 403xxx bit is OK.

Next, do you have a Cullman phone interface? That would be unusual, more normally this would be xxx7xx if in Europe or xxx6xx if in US (or xxx1xx if you don't have an Audi phone interface).

There is NO digital radio for the RNS-E so the next digit MUST be wrong. If you have a satellite receiver (XM or Sirius) this should be xxxx3x, but if you don't this should be xxxx1x.

And the final digit, if you have a CD changer and an MFSW then xxxxx7 is fine.
 

·
Registered
Joined
·
6,767 Posts
xxx7xx if in Europe or xxx8xx if in US
Actually it's xxx7xx if in Europe or xxx6xx if in US
 

·
Premium Member
Joined
·
11,350 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #8 ·
Thank you all guys for you precious support.
Actuly my car is an A4 Cabrio 2004. I have a cullman adaptor which is mounted in the armrest.
I will try the codings you mentioned above and send you the feedback.
But isnt it ubnormal to have the workshop field under the coding field hidden??(i cannot change its value)
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #10 ·
It Worked

I tried the codes you gave me and it worked.
But the tel gives me a message: note please use you mobile phhone.
but when i use it the message does not change and i cannot get the phone book and make phone calls at my head unit:((
 

·
Premium Member
Joined
·
11,350 Posts
What is the coding of the phone module (address #77)?
 

·
Registered
Joined
·
6,767 Posts
That likely means that you live outside North America and that your phone interface is too old to support the enhance features.
 

·
Registered
Joined
·
530 Posts
I wouldn't expect to be able to reliably connect to a phone module with VAG-COM version 409 and an aftermarket cable.

Either buy/borrow an original VAG-COM cable and run the latest version of VAG-COM (607?) or pop into a dealer and get them to check/recode the phone module.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top