Audi Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi,
I've got the CD-based Navi+ in my Audi A6 3.0 Quattro 2003 that I bought in Germany (I live in Sweden, Europe).

It's worked fine until a week ago. I was flipping through the menus, mostly the radio menus. After that (I don't know if it's related) I always get an error message that I've never seen before:
------
RDS-TMC tuner:
Connection to RDS-TMC tuner is faulty or could not be established.
------
I can live with this. I just have to confirm it, then it comes back and I confim once again. Then it's gone until I restart the navi. It's annoying but not too severe I think.

What's worse. Much worse. Is that the onboard computer on the dashboard doesn't show any Navi-information anymore. It doesn't show any radio-info either (like station name/frequency).

Do you think a cable connection is loose, or what?
I think it's related to my tampering with the menus but I've honestly tried my best to find the problem without success.
How do I remove the Navi to see the wiring? I guess there is a guide somewhere?

Really would appreciate all help I can get!
Anyone in the Karlstad area in Sweden will get a free "discover scuba diving" for helping me :p
Br, ((( DiveMaster )))
 

·
Registered
Joined
·
4 Posts
Same Problem

Sorry to say that I can not help, but I do suffer from the same problem. Mine is from an A6, and the model nav is M. I just installed it in July and it started doing this in August (I live in the US, btw). Anyway, I think it may be a faulty TMC unit (that is my hope anyway, because it is way cheaper than a new nav). I think this because the unit still works when this happens (albeit slower) and the steering wheel functions cease to work.

Ways to test this would be trying to replace the TMC with another one if you can get your hands on it, VAG the NAV so that it doesn't look for the TMC unit anymore and see if that works, or ask an Audi dealer.

Mine started rarely, but now it happens every time I turn on my car after it has been sitting a while (overnight or more). I thought I could live with it too, but it's very annoying now.

Please keep us posted, and good luck (I'll do the same if I figure anything out)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
One more with this problem on a German site

Hi,
it seems to be hard to find the solution to this problem. I went to the Audi dealer in my town today and they had never heard of this problem before. They said they could connect it to their computer system to see if they could find out more about the problem. So I guess I will do that next week.

I also found a german guy with the same problem. My german is not too good though, but he had 2 problems and got an answer to the second one. Of course he didn't get a reply to my problem...
http://navi-forum.net/board/viewtopic.php?t=19340

Is there really no one who can help with this ???

Br, ((( Divemaster )))
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
And here is yet another guy with the same problem

As I understand it they suggest that he buys a TMC-box on eBay. I'm not sure but it looks like not all of them have the Gateway features, which means that some won't get the FIS to work. I guess the FIS is the display behind the steering wheel, which doesn't work for me either. However it doesn't really help me since it used to work just weeks ago without problem. Now it stoped working. I guess my problem really could be the connection, or the TMC-tuner just crashed. That's what Audi will tell me I'm sure. Easisest for them and most $...

Here is the new link I found...
http://navi-forum.net/board/viewtopic.php?t=17827
 

·
Registered
Joined
·
996 Posts
I'm not sure if the TMC is faulty. Those units are rarely defective. I would check the wiring to/from the unit and see if it is getting power. It could be a number of issues....but I'm not sure what could have disrupted the power to the TMC gateway.

Was this TMC/CAN factory installed or did you add it when you installed the Nav+?

Did you check the pins behind the 26 pin connector behind the Nav+ to see if something as come loose?

Is there a fuse that needs to be replaced?

Not sure....just providing some guidance.

-ted
 

·
Registered
Joined
·
22 Posts
you guys who are having TMC problems may want to test this out. instead of connecting both Can H and CAN L wires from 26pin to TMC then CAN H and CAN L to dash . just connect CAN H from 26pin to TMC unit leaving CAN L disconnected. When i was installing a friend's nav with tuner tv i couldn't get the tmc to work consistantly using the standard wiring method but i devised the above connection and it worked perfectly. I only connected CAN H from tv tuner to pin26 Can H and Can H from pin26 to TMC then Can H to dash. This led me to think that Can L is not even needed for gateway function.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
The solution

Hi,
I'm almost too embarrased to tell you this, but when I removed the fuse #37 (big fuse for Radio) and then tried it... guess what... it worked. Thanks for helping me. I hope anyone with this problem can solve it as simple as I could.
Br, ((( DiveMaster )))
 

·
Registered
Joined
·
4 Posts
Great News!

I will try this over the weekend as well. Did you replace the fuse? Was it blown? Or did you just take out a good fuse?

Thanks

Chuck
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
It was an ok fuse

Hi,
There was nothing wrong with the fuse at all. I'm a computer engineer and I know that software can sometimes "hang" so you need to reboot the hardware to get it running again. This is why I was embarrased that I didn't think of it right away.

About the fuses. In the instructors manual for the A6 it said that the fuse for the Navigation is #10. It wasn't. I also tried some others. In the plastic cover to the fuse box it said that it was some other fuse which it wasn't. Then I tried the one which I think said Telephone/Radio, and that helped.

Good luck! I hope it solves your problem too.
Br, ((( DiveMaster )))
 
1 - 10 of 10 Posts
Top