Audi Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
Does the RNS-E phonebook requires the BT OBEX profile to work?

My '06 B7 came from the factory with the scroll wheel MSFW & BT. I've retrofitted the RNS-E, revision F. I have a Canadian Telus Motorola V710 (BT without OBEX profile).

My cell phone can connect via BT no problem. Everything works fine except one thing.

Right now I can scroll through my cell's phonebook via the MFSW scroll wheel (this also worked before the retrofit), but my RNS-E's phonebook entry is not available. Is this because the phonebook requires the OBEX profile to transfer the data?
 

·
Registered
Joined
·
6,767 Posts
Once the phone is paired to the interface, the RNS-E should have the same access as the mfsw. What software do you have on your RNS-E? To get the phone features you need at least sw 0110 fromt he 2006 DVD.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #3 ·
I have sw110.

All TEL functions of the RNS-E is working fine, except for the phonebook.

I bought the unit from someone without BT. Is the wiring different?
 

·
Registered
Joined
·
6,767 Posts
The wiring is always the same. The only reason I can think of is that your Canadian V710 is not fully compatible with the Audi BT interface. Although it makes no sense that the interface can read the phonebook but the RNS-E cannot. I was under the impression that the RNS-E is just another remote control for the phone inteface therefore it should behave exactly as the MFSW/DIS.
 

·
Registered
Joined
·
84 Posts
I think this is a coding issue. I forget the details now, but I think you need to tell the BT unit that the headunit understands the phone book etc.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #6 ·
Just finish reading the entire thread of PROXUS's BT project. I think my problem is my coding in module 77.

I have an 06 B7 the following config:
- scroll wheel MSFW
- factory BT
- RNS-E revision F, H/W 70, S/W 110

I think my module 77 code should be 00?2877.

What databus type should I use in my code? 0 (CAN), 1 (C6 high), or 2 (C6 standard)?

Or am I completely off track?
 

·
Registered
Joined
·
6,767 Posts
The "?" should definitely be a "1", otherwise you won't get any control from the RNS-E. Teh comment "C6 high" is wrong, this coding is not dependend on the C6 model, except maybe that it enables features similar to the C^ HIGH MMI.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top