Audi Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
I've just removed the Onstar, and replace with the BT module, switching the ten pins from the 42 pin connector to the 54 pin connector.

I'm have the current softwate on the RNS and VAG. I'm in the process of re-installing the VAG software, just to see if there are issues there.

Issue #1-

I could not change the coding on the head unit, via Navigation or Radio (37/56) which is currently 0309637. I tried recoding the "6" to "2" ans "7". It would not accept either code.

The message on the RNS, in TEL mode is:

"Your telephone might not be connected or inserted properly".

Issue #2-

I used my phone (Motorola Razor) to see if I could see the BT module, and I can. It sees: Audi UHV 8218, and when I try to connect it askes for a Bluetooth pass key. Ofcourse, any entry I enter gives me an invalid pin number. Is there a default key?

So......any help here would be greatly appreciated.
 

·
Registered
Joined
·
6,767 Posts
If you are in the US, the 6 is the number you need to enable phone support. The 7 is for European interfaces only.

The default BT key is 1234. If your RNS-E is running the US 0110 software (required for full phone support) you can change the key under setup.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
Thanks for teh quick reply.

The 1234, was the ticket. Bt, I can't change the pin, as the Bluetooth pin entry is ghosted.

I also can't send/retrieve the numbers stored on the cell phone.

I'm part way there, and at least it looks like I'm electrically hooked up.

I'll need to check my cellphone.

I also can't access the BT moduel via VAG (77).
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
Here is where I'm at.

I can make calls, and recieve calls. The DIS no longer displays the number being called, as it did with Onstar. Still can not connect to the BT module via VAG. Latest software, etc.

Thanks again for all your help!!
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
Coding 77.

I think not being able to code the BT module is the issue.

Hex-Com and latest software, but it will not connect. "To many communications errors" is the only message.

I'm fairly certain I need 12877 for a code, but I just need a to communicate to the unit.

2004 B6 S4, Multi function, RNS-E, DIS.

Thanks again.
 

·
Registered
Joined
·
6,767 Posts
If you are using VAG-COM 512.4 keep trying. Several people had issues to get connected.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #7 ·
Some success.

I finally did get to communicat with the BT mod. I had to toggle off everything else on the computer, and ensure that the phone was paired with the unit. I tried the codes but it is asking for a seven digit code, and I have some codes to play with. By the time I researched possible codes, I could not amke contact again.

I'll try again this weekend.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #9 ·
All set!

Thanks for the help. The first code took, and erything is up and seems to be running.

I had to toggle off most the items running in the back ground in windows. I also had to try and connect while the phone was paired with the car. And then try again after the car dumps the phone, as it usually would connect then.

I now have full access to my phone book and voice dialing with the BT module. Outstanding addition.

I love the RNS-E more every day.
 
1 - 9 of 9 Posts
Top