Audi Forum banner
1 - 20 of 49 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have On-Star on my 2002 A6 and I was wondering if I still need to add a microphone for blue tooth because On-star all ready have a microphone?
 

·
Registered
Joined
·
6,767 Posts
If you are going to replace OnStar with the BT FSE you can re-use the components. In the A4 B6 it seems to be a straight swap, in the A6 C5 there might be some issue with the size of the power wires. Either way, the microphone should be the same.
 

·
Registered
Joined
·
996 Posts
What if you want to have both OEM or aftermarket Bluetooth (or any handsfree kit) and Onstar at the same time? It seems that this is a very rare occurrence as only a few B6/B7/C5's have Onstar. The ones that do...really don't use it that much.

I found that someone was able to add a relay on the tele +/-, mute wires between the HF kit and onstar (as they both would use the same inputs into the RNS-E).

Here are the related posts that I've been tracking:
http://www.navplus.us/forum/viewtopic.php?highlight=onstar&t=1518
http://www.navplus.us/forum/viewtopic.php?highlight=onstar&t=791
http://www.navplus.us/forum/viewtopic.php?highlight=onstar&t=1693
http://www.navplus.us/forum/viewtopic.php?highlight=onstar&t=922

Pix of rear pin-outs of Sym II (and Sym I) for reference:
http://www.vwnavi.com/vwnavi/photos/albums/userpics/Slide2g.JPG

Can anyone post pix, parts of what kind of relay was used?

Thanks!
-ted
 

·
Registered
Joined
·
1,624 Posts
All you'd need is a 12VDC DPDT relay with the N.O. contacts connected to the device who's mute line is used to trigger the relay. Then connect the second device to the N.C. contacts. I forget who originally posted this idea, but it is a elegantly simple solution to the dual tel audio input problem.

Even though the Onstar telematics module will probably be used less, I would still choose this for the N.C side of the relay... just in case you're ever in a bad situation where onstar is needed, but the battery power has been lost. In this case of lost battery, the relay would default to the onstar module as the audio source.
 

·
Registered
Joined
·
87 Posts
I have a bluetoth kit on the way and I have OnStar... so i will give this a shot and let you guys know if i can get it working. Figured i woudl go ahead an try to keep the OnStar functioning just in case.
 

·
Registered
Joined
·
8 Posts
Bluetooth and Onstar working.

Just installed Bluetooth kit today from Proxus (excellent seller).

Installed behind glovebox, ran mic to the light dome.

On the right of the standard onstar microphone, there is a cylindrical hole/tube that lines up with an extra microphone grill. If you take the plastic housing off the Audi mic, leaving the copper cylinder around the mic it fits right in there. Now I have two mics, one for onstar which works as it did before and one for bluetooth.

On the headunit side, I moved the old nav/onstar (NF+/-) wires over to the TEL+/- and added T-taps to TEL+/-/Mute wires to add the bluetooth module audio. Haven't noticed any audio problems yet and both seem to work.

Treo 650 seems to be fully working, with missed/receieved calls and signal strength all being displayed correctly.
 

·
Registered
Joined
·
87 Posts
Re: Bluetooth and Onstar working.

Speedy said:
Just installed Bluetooth kit today from Proxus (excellent seller).

Installed behind glovebox, ran mic to the light dome.

On the right of the standard onstar microphone, there is a cylindrical hole/tube that lines up with an extra microphone grill. If you take the plastic housing off the Audi mic, leaving the copper cylinder around the mic it fits right in there. Now I have two mics, one for onstar which works as it did before and one for bluetooth.

On the headunit side, I moved the old nav/onstar (NF+/-) wires over to the TEL+/- and added T-taps to TEL+/-/Mute wires to add the bluetooth module audio. Haven't noticed any audio problems yet and both seem to work.

Treo 650 seems to be fully working, with missed/receieved calls and signal strength all being displayed correctly.
So do you have both OnStar and Bluetooth working together (not at the same time.. but both usable?) That is what i think you are saying.. and if so....(grrrr.) I am going to yank my Bluetooth module our from under the seat, reinstall OnStar, and go with both.
 

·
Registered
Joined
·
87 Posts
Re: Bluetooth and Onstar working.

Speedy said:
Just installed Bluetooth kit today from Proxus (excellent seller).

Installed behind glovebox, ran mic to the light dome.

On the right of the standard onstar microphone, there is a cylindrical hole/tube that lines up with an extra microphone grill. If you take the plastic housing off the Audi mic, leaving the copper cylinder around the mic it fits right in there. Now I have two mics, one for onstar which works as it did before and one for bluetooth.

On the headunit side, I moved the old nav/onstar (NF+/-) wires over to the TEL+/- and added T-taps to TEL+/-/Mute wires to add the bluetooth module audio. Haven't noticed any audio problems yet and both seem to work.

Treo 650 seems to be fully working, with missed/receieved calls and signal strength all being displayed correctly.
Okay, I am seriously thinking about this.... hmmm.
So what would i need to do? I think i get the "mic" install. But as far as the HU wiring... what did you use for power? And why did you move the Onstar wires? Just want to make sure i know exactly what i need to do before i go and rip the car up again. thx.
 

·
Registered
Joined
·
6,767 Posts
I coded by cluster once for phone (+2) and Telematics (+8) and it got seriously confused when making a call through the BT interface (changing constantly between PHONE and MP3). Haven't done much testing but since Audi never offered both together I don't think the cluster will be able to handle this.

The other issue is that there is only one Phone NF+/NF-/Mute in. To do it right you would need to use some relay/switch to have only one source using the input. Otherwise you may confuse the other interface. That's all theory of course but the cleaner installer is definietly to use only one of both interfaces.

In addition to that is analog OnStar going to get retired (later this year I think) and without a digital OnStar interface it's pretty much useless.
 

·
Registered
Joined
·
87 Posts
AudiA4B6US said:
I coded by cluster once for phone (+2) and Telematics (+8) and it got seriously confused when making a call through the BT interface (changing constantly between PHONE and MP3). Haven't done much testing but since Audi never offered both together I don't think the cluster will be able to handle this.

The other issue is that there is only one Phone NF+/NF-/Mute in. To do it right you would need to use some relay/switch to have only one source using the input. Otherwise you may confuse the other interface. That's all theory of course but the cleaner installer is definietly to use only one of both interfaces.

In addition to that is analog OnStar going to get retired (later this year I think) and without a digital OnStar interface it's pretty much useless.
Thats right... Audi Onstar is analog, rigtht? So i am guessing they didnt; offer any kind of upgrade to the new system (since it seems like Audi has parted ways with Onstar.) Lexas had the same issue. They had something called "Active Lexus".. or something like that. Basically an inhouse Onstar.. but it was analog and they had to retire the entire system since the teleco they were partnering with killed the analog system.
 

·
Registered
Joined
·
8 Posts
You're right, ideally I'd have a relay for the 3 wires, but it seems to be working for now.

In the symphony II, the onstar/BNS audio came in on seperate pins from telephone, the RNS-E only has telephone +/-/mute now so it was just a case of moving the old NF+/- to hookup to TEL+/- and onstar would work again.

Then I used T-taps to piggy back the bluetooth audio signals in on those same 3 wires.

As far as the instrument cluster display, I still need to see how it behaves. Audio-wise onstar works normally. I don't really use Onstar, but I hate having non-functional buttons and equipment in the cabin. :)
 

·
Registered
Joined
·
8 Posts
Played around more today, looks like onstar text isn't displayed on the DIS.

With the phone tapped into the onstar wires, there's also a volume decrease in the phone. I'll have to wait till i get to working on a relay, until then Onstar audio will be disconnected from the RNS-E.

On the plus side, it was nice to find the additional microphone spot in the B6 light dome.
 

·
Registered
Joined
·
5,817 Posts
ok, guys I need some help. I just sit with BajoRS6 in his car now and we are trying to find out why tel audio has very low volume. We can barely hear it. I see that he got OnStar I believe we need to disable it.

Can anyone tell which pins in the harness need to be moved and where?
All other functions are working sweet.

Thanks ;)
 

·
Registered
Joined
·
6,767 Posts
Unplug the 10pin connector which has the TEL NF+/NF- and Mute wires and see what happens.
 

·
Registered
Joined
·
5,817 Posts
I played with that already but nothing happens,
We disconnected OnStar controlls but that didn't changed nothing either,.
I don't want to remove telematics box from under the seat if there is simplier method of making this work., and basically everythin is working fine except that very low tel audio signal.
 

·
Registered
Joined
·
1,624 Posts
Is the onstar module still conencted fully to the 42-pin connector? If so, this cannot be. If you want both modules connected, you must use a relay to swtich between audio sources (BT or telematics)... instead of having them both connected at the same time.
 

·
Registered
Joined
·
5,817 Posts
I just need TEL module. Bajo said that he doesn't care about OnStar.

By the way...Does anyone know if under VAG - Electronics1 - Telematics 75 is possible to activate and deactivate OnStar? Soft Coding is there bt no descriptions.
 

·
Registered
Joined
·
1,624 Posts
I suggest you pull the plug on the telematics module in this case. You have to disconnect the emergency battery as well.
 

·
Registered
Joined
·
5,817 Posts
so the only way is to remove seat and disconnect this bastard?
Is OnStar even located under passanger seat in 2002+ A6/RS6?
 
1 - 20 of 49 Posts
Top