Audi Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5,817 Posts
Discussion Starter #1
I have VAG HEX-USB with latest 510beta. I'm trying to connect (on desk) RNS-E to VAG via OBD2 connector but I have some problems.
I found pins description and Dirk & Craig confirmed that only K-Line & POWER is necessary to code RNS-E.

My connected wires are:
pin 5 - GND
pin 16 - 12V+
pin 7 - K-line

but it doesn't work :evil: I tested this wil power supply and in car cigaret lighter, same thing - LED is off.
I tought that my VAG cable is faulty but when I connect it direct into car OBD - everything is fine.

Do you have any ideas




This is General pin description:



Pin 2 - J1850 Bus+
Pin 4 - Chassis Ground
Pin 5 - Signal Ground
Pin 6 - CAN High (J-2284)
Pin 7 - ISO 9141-2 K Line
Pin 10 - J1850 Bus
Pin 14 - CAN Low (J-2284)
Pin 15 - ISO 9141-2 L Line
Pin 16 - Battery Power :?:
 

·
Registered
Joined
·
1,624 Posts
You may want to connect both pins 4 and 5 to ground.

Also, on my car, pin 1 connects to terminal 15. Therefore, you may want to also connect this pin to battery power so your cable thinks that the "ignition is on".
 

·
Registered
Joined
·
6,767 Posts
Here's what I'm using to bench test with VAG-COM:

pin 1 - 12V+
pin 4 - GND
pin 5 - GND
pin 7 - k-Line
pin 14 - L-Line (or k2)
pin 16 - 12V+

I can connect to my RNS-E using the k or the L line but to connet to the phone interface I have to have the RNS-E connected to L and the phone interface connected to k.
 

·
Registered
Joined
·
3,759 Posts
I'm using 4 or 5 for GND (can't remember which), 16 for +12V and 7 for Kline, no problems talking to RNS-E or phone modules since 5.10 beta came out. I've disconnected the can gateway module that I was using.

Craig
 
1 - 6 of 6 Posts
Top