Audi Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5,817 Posts
Discussion Starter #1
I need some help....I'm installing A6 unit into 2001 A6 4.2 with existing navigation. This is what I did:

- I disconected connectors from old navigation (in the trunk)
- Connected GALA from white wire with blue stripe (blue conector)
- Connected CAN-H & CAN-L from gray connector

what is weird that pin 5 & 6 was already used by orange wire with brown stripe and orange with purple stripe. (I guess it was used by old nav). Either way I patched to those cables.

Now the problems....and sympthoms

- when ignition is off, everything is fine. I can type security code and listen to radio etc.
- when I turn ignition ON navigation screen is going back to code entry, but when I type code again it is going to code antly screen again ....and again and again...
- same thing if ingnition is OFF but I'm turning lights ON (lights for DIS to be exact)
- same thing if ignition is OFF radio is playing and I'm trying to get to NAV through VAG. I have a problems to connect but from time to time I can.

To eliminate some of the possibilities I did some tests:
- I can see clock on the screen and it reads cluster clock.
- tested this NAV in my car and everything works fine so NAV is not a problem
- I removed those 2 existing CAN wires and connected separate ones but same thing.
- I entered code few times when inginion and lights were ON and each time for a second I see button lights so I guess GALA connection is fine.

To be honest I'm running out of ideas :shock: I tested everything few times and don't have a clue. I did installs on 7 A6 already and never had problems like that. Do you guys have a clue what I should do?

I suspect that something is interrupting CAN signals because I have problems to connect to NAV with VAG.

Any ideas?
 

·
Registered
Joined
·
517 Posts
With respect to the repeated code entry, you can try two things:

1. turn the ignition and the RNS-e off and let it sit for more than half an hour to make sure the RNS-E turns completely off. Then try it again.

This happens to me (2001 A6) every time I have the cluster out or when I update the firmware in the the RNS-E. Like today when I updated to US 0110 firmware, kept on cycling to code entry whenever I turned ignition on. Shut the car off and went to do something else for 45 minutes, went back and everything back to normal.

2. Other people have reported that they have gotten rid of the problem by just resetting the unit.

With respect to the VAG-COM problem, I believe VAG-COM talks to the RNS-E via the K-line (not CAN), so that sounds like a different problem.
 

·
Registered
Joined
·
149 Posts
This is a known problem in the older A6 models.
Press RADIO + SETUP @ the same time and the system will have a hardware reset.. If it's ok, everything will work fine

Tony
 

·
Registered
Joined
·
5,817 Posts
Discussion Starter #4
thanks guys,

I tried to reset unit but no luck.

Also just to make it clear....by screen going beck to entry code screen I mean ..it like that every time I enter the code not every time I turn of the car.

So I'm entering code and for a sec I see warning screen (and buttons lit) and then it is going back to entry code (still showing 2 attemts for entering code).

Also when I'm in STG 56 in VAG I hear something like pinging every few seconds, something like VAG is trying to communicate but have some problems with it.

I totally don't have a clue :?
 

·
Registered
Joined
·
6,767 Posts
Did you tripple check the K-wire to make sure that VAG-COM can talk to the RNS-E? And even though you said you did it, the symptoms you describe regarding entering the code are usually fixed by resetting the RNS-E (press RADIO+SETUP until it reboots).
 

·
Registered
Joined
·
5,817 Posts
Discussion Starter #6
I had it working for a while with car on but next time I started car it went back to previous state. I will try to reset method and double chceck K-Line again ;) Thank you.
 

·
Registered
Joined
·
517 Posts
Your description perfectly fits how my RNS-E behaves and leaving the ignition off for 30+ minutes always fixes it. Have you checked that the RNS-E completely turns off after 30 minutes?

One other point, which I doubt has anything to do with this problem, on a 2001 A6 you should not take the GALA signal from the cluster, the correct signal is available on the radio connector since the Symphony I radio uses it. As a matter of fact, it is the most common complaint for the RNS-E adapters, that the vendors forget to put the wire in for pre 2002 A6s.

I have never heard the pinging you are talking about. Does it come from the speakers, and does it mute the radio during the beep. When I scan my car for faults, there is a point during the radio and nav phases, where it will briefly mute the sound and beep. I wonder if you could have a noisy K-line. I guess it had to go to the trunk to reach the old NAV unit.

Sorry, I can't think of anything better at the moment.

Guess AudiA4B6us beat me to it while I was typing :D
 

·
Registered
Joined
·
5,817 Posts
Discussion Starter #8
I will try that as well.

Yes I hear pinging noise when radio-56 is accessed. Radio is muted but I can hear this noise.
 

·
Registered
Joined
·
517 Posts
You probably already tried this, but let me mention it anyway :)

If the two existing CAN wires go to the trunk, and are not connected to anything, that could make for an unhappy CAN bus (unterminated stubs that long are a clear violation of the CAN spec).

I know you tried to disconnect the two wires, but I am wondering if the (normal) behaviour of having to reset or leave unit off to get rid of the problem, might have confused the experiment.

So if you have not already tried this, I would do what Dirk and I suggested with the two old CAN wires disconnected.
 

·
Registered
Joined
·
5,817 Posts
Discussion Starter #11
Thanx guys...

...after 10 minutes you can actually hear through speakers little ping noise and unit is loosing power completely.

after that everythin is working fine - no passowrd input nedeed anymore
 

·
Registered
Joined
·
59 Posts
That's exactly how my car was working. I also have the factory nav. Removing the CAN connection at the cluster to the old nav and resetting the unit fixed it for me, too.

As for the pinging, it it like a morse code? Do you have a PhatBox? On the Symphony I, the PhatBox works instantly and flawlessly. On the RNS-E, I hear something like morse code coming from the back of the car, and then the PhatBox works, although not as crisply as with the Symphony I.
 

·
Registered
Joined
·
11 Posts
Anyone figure the radio PIN code issue out yet?

I'm having the very same problem with the radio code.

When I have the CAN bus connected, I can enter the code, and it bounces back to the enter-code screen. Always. Without fail.

When I disconnect CAN, everything works 100% (including illumination), except of course the instrument cluster gets no navigation info.

Plug in the CAN connector, and it bounces back to the PIN screen again. I've tried letting it sit for an hour, with no luck at all.

Proxus, I do hear the morse-code like beeping too. Not a clue what that means.

SO... how do I make this work? Did I get a defective unit?
 

·
Registered
Joined
·
11 Posts
Hah, it works!

Ah hah! It works...

I had to enter the code with CAN disconnected, then plug in CAN, and wait a while. When I got up this morning and checked it, I entered the code once, and it worked perfectly.

How strange!
 
1 - 14 of 14 Posts
Top