Audi Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
Well, it's ALMOST working. :) (and almost fitting :D)
What was cool was it was a direct hookup... no adapters or anything needed. However, I might have to make an adapter to sort out the VW-related issues.

Questions for you guys --
1. I go to choose a route, enter the information, and it says the "Route could not be calculated" or something? This is the latest software version, but the maps disc is a burned copy.
2. If I zoom out to like 900ft or more, the map disappears... is this just me or do I have a bad map disc?
EDIT: BOTH problems were fixed with a new Map disc. The old one was junk.

(streets blacked out for privacy)


 

·
Registered
Joined
·
6,767 Posts
The map doesn't disappear but some details do. And the fact that you don't have a time shown indicates to me that you didn't hook up your GPS antenna yet.
 

·
Registered
Joined
·
300 Posts
OK VW Fans lets jump on this. I want to install the MFD into my Passat W8 . I have Lanny looking into helping make/source a true can bus emlulator becuase the VW and Audi Canbus are different. In earlier experiments I noticed the following , while the unit plugs in, it will not turn on and off, I never verified if it actually navigates, i.e. is getting the GALA signal, and it will not communicate with the FIS.

I was hoping other folks are interested in making this fully work.

Steve


smash said:
Well, it's ALMOST working. :) (and almost fitting :D)
What was cool was it was a direct hookup... no adapters or anything needed. However, I might have to make an adapter to sort out the VW-related issues.

Questions for you guys --
1. I go to choose a route, enter the information, and it says the "Route could not be calculated" or something? This is the latest software version, but the maps disc is a burned copy.
2. If I zoom out to like 900ft or more, the map disappears... is this just me or do I have a bad map disc?

(streets blacked out for privacy)


 

·
Registered
Joined
·
155 Posts
Discussion Starter · #4 ·
AudiA4B6US said:
The map doesn't disappear but some details do. And the fact that you don't have a time shown indicates to me that you didn't hook up your GPS antenna yet.
It works perfectly though, I went for a drive earlier and it followed the map after it calibrated. :) Very nice
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #5 ·
Steve Z1 said:
OK VW Fans lets jump on this. I want to install the MFD into my Passat W8.
Isn't the W8 a 2002 though, I think they changed the radio connector in 2002.5 or 2003.

Regardless the thing works pretty damn well, I think I just have to switch some wires around or something. So far I have the following problems:
1. The rear speakers don't work because it's an Audi radio. (will fix this first)
2. EASY FIX (I hope): The alarm doesn't chirp from the keychain anymore since the radio's different.
3. FIXED (?): I went outside and the lighting was off, but it turned on when I opened the door. Perhaps it's just delayed or there for ambient purposes? We'll see Even though the radio turns off and on with the car, the backlighting of it stays on no matter what. (even if the headlights are off, or the car's off)
4. MINOR: FIXED (?): I think this resolved itself when it calibrated after around 10 minutes of driving. I'm not sure if it's reading the correct speed from the car, but I'll have to double-check this.
5. MINOR: It's not 100% working with my iPod adapter. (which is wired through the CD changer); it's only seeing CDs (playlists) #5 and 6. It was working before, but I think this particular 3rd-party adapter (provided by USAspec) isn't as well made as some of the others... and the Audi radios seem to be pickier than the VW.
 

·
Registered
Joined
·
530 Posts
Sorry I can't help with your questions but just wanted to say good job on the install - the RNS-E makes a great addition to the awesome R32!

I'm about to do the install in my B6 A4 Turbo Quattro - got all the bits and pieces, just need to find the time to put it all in (including the double din conversion w/ new climate control)!
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #7 ·
It's actually working pretty well. It "learned" the dynamics of the car, I just think I have a bad map disc.

In a parking lot, was going like 8 or 9 MPH
 

·
Registered
Joined
·
300 Posts
Thanks for writing back.

Clarification the W8 has the same quad lock connector as your car and the RNS-E unit.

I noticed you used the A4 unit. I would have thought the A6 would be the better choice, but I appear wrong.

How did you get the unit to fit as in slide in, the VW and Audi have different double din cage / radio guides, you know the metals guide on the side of the RNS unit does not work with the VW radio cage.

When the unit navigates it literally is following an updating real [email protected] TIf that is the case that is amazing.

Please provide more details on how you actually fit the radio it will really help the other folks interested.

Steve

smash said:
Steve Z1 said:
OK VW Fans lets jump on this. I want to install the MFD into my Passat W8.
Isn't the W8 a 2002 though, I think they changed the radio connector in 2002.5 or 2003.

Regardless the thing works pretty damn well, I think I just have to switch some wires around or something. So far I have the following problems:
1. The rear speakers don't work because it's an Audi radio. (will fix this first)
2. EASY FIX (I hope): The alarm doesn't chirp from the keychain anymore since the radio's different.
3. FIXED (?): I went outside and the lighting was off, but it turned on when I opened the door. Perhaps it's just delayed or there for ambient purposes? We'll see Even though the radio turns off and on with the car, the backlighting of it stays on no matter what. (even if the headlights are off, or the car's off)
4. MINOR: FIXED (?): I think this resolved itself when it calibrated after around 10 minutes of driving. I'm not sure if it's reading the correct speed from the car, but I'll have to double-check this.
5. MINOR: It's not 100% working with my iPod adapter. (which is wired through the CD changer); it's only seeing CDs (playlists) #5 and 6. It was working before, but I think this particular 3rd-party adapter (provided by USAspec) isn't as well made as some of the others... and the Audi radios seem to be pickier than the VW.
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #9 ·
Steve Z1 said:
Please provide more details on how you actually fit the radio it will really help the other folks interested.
To get the radio in, I had to clip a way for the support to get through on one side. (if you angle it in, it'll fit)



Right now it doesn't sit flush, but I plan on modifying the trim so that it at least sits flat on the dash. Looks very nice and fits the bay perfectly.

In addition, it does navigate in real time. For some reason I can't get the routing to work, though. I'm working on it.
 

·
Registered
Joined
·
300 Posts
Thanks!!

Steve

smash said:
It's actually working pretty well. It "learned" the dynamics of the car, I just think I have a bad map disc.

In a parking lot, was going like 8 or 9 MPH
 
Joined
·
357 Posts
smash said:
Steve Z1 said:
OK VW Fans lets jump on this. I want to install the MFD into my Passat W8.
Isn't the W8 a 2002 though, I think they changed the radio connector in 2002.5 or 2003.

Regardless the thing works pretty damn well, I think I just have to switch some wires around or something. So far I have the following problems:
1. The rear speakers don't work because it's an Audi radio. (will fix this first)
2. EASY FIX (I hope): The alarm doesn't chirp from the keychain anymore since the radio's different.
3. FIXED (?): I went outside and the lighting was off, but it turned on when I opened the door. Perhaps it's just delayed or there for ambient purposes? We'll see Even though the radio turns off and on with the car, the backlighting of it stays on no matter what. (even if the headlights are off, or the car's off)
4. MINOR: FIXED (?): I think this resolved itself when it calibrated after around 10 minutes of driving. I'm not sure if it's reading the correct speed from the car, but I'll have to double-check this.
5. MINOR: It's not 100% working with my iPod adapter. (which is wired through the CD changer); it's only seeing CDs (playlists) #5 and 6. It was working before, but I think this particular 3rd-party adapter (provided by USAspec) isn't as well made as some of the others... and the Audi radios seem to be pickier than the VW.
Bringing back this thread. I have pretty much the same issues in my 2002 VW Passat with Monsoon (external amp).

1. Rear speakers do not work
2. Alarm doesn't chirp with the radio installed (because I believe the car knows the radio is still on)
3. The backlighting and fan stays on after turning off the unit and arming the alarm. Been told it will turn off after 1/2 hour but that can't be good for the battery!


Any advances?
 

·
Registered
Joined
·
300 Posts
I was thinking why the rear speakers do not work, and I think the answe has to do with the way the RNS-E unit is coded. I think if the rear speakers are not working it means it is coded for Bose, try re-coding the unit for a non Bose car, I think this will solve your problem. The others are all canbus related and the fact that the Audi and VW use slightly different data packages.

Steve
 
Joined
·
357 Posts
Hey Steve,

Thanks for the input. Yes I was thinking about the coding as the rear speakers are not amplified through the RNS-E. I do have the Monsoon amp that came stock with the car and was thinking that should be powering all the speakers. However, when I tried to connect to the Radio and Navigation control modules, my vag com was unable to connect.

The communication takes place over the K-Line? I guess I should check that. Good thing is I have the CAN(+)(-) connections already.



I am missing D13 (U14 St DSP (Radio On)) and D11(Tel-Mute).

Will have to check connectors B and C.
 

·
Registered
Joined
·
300 Posts
I am 99% sure the vag-com is communicating through the "K" line.

Also can you post some pictures of how you have the head unit installed in your Passat. I want to try to retrofit the RNS-E into my Passat and I really do not want to change the switch location. I am hoping if the switches get moved outboard as far as possible and if I need to trim the head unit there will be enough room.

Steve
 
Joined
·
357 Posts
Will post a pic, but I had the MFD2 installed from dvsails setup, and so my switches were already placed along the bottom. My fit is flush along the top of the navi and the face plate will only consist of the sides where the old buttons used to be.

But thinking about your idea placement sounds good. Are the small phillips screws holding the face plate in place? If you removed the face plate surrounding the screen and buttons, it should be real easy to trim it down and keep the buttons in place. As is, there is barely enough room for the buttons to be in the original position, but with the face narrowed, the buttons should be able to stay in place!
 

·
Registered
Joined
·
300 Posts
OK I know there is someone out there with an A3 unit in their Passat..I remember reading about it in Passatworld..

Thanks though..

Steve
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #18 ·
[email protected][dartmouth said:
]Bringing back this thread. I have pretty much the same issues in my 2002 VW Passat with Monsoon (external amp).

1. Rear speakers do not work
2. Alarm doesn't chirp with the radio installed (because I believe the car knows the radio is still on)
3. The backlighting and fan stays on after turning off the unit and arming the alarm. Been told it will turn off after 1/2 hour but that can't be good for the battery!


Any advances?
1. If the re-coding doesn't fix it, it's because there's only front outputs. Jump the speaker wires together (split the power between front and back)
2. Depin the alarm wires. :?
3. I never solved that problem but you might want to order a CAN Emulator (even though you have a can-bus already)

Overall I didn't want the hassle and just swapped in a Pioneer AVIC-Z1 instead.
 

·
Registered
Joined
·
8 Posts
Hi!
I am from Portugal (sorry for my English) and I also want to put an RNS-E at my VW GOLF IV GTI TDI from 1999.
I need to know some things if you van answer me.
What is your RNS-E version? I have one RNS-E version D of an Audi A4 does it fir or does it have to be the A6 model?
My car doesn´t have Can Bus, Do I need a Can Bus Simulator? If yes is the one like to the old Audi?
Greetings llduro
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top