Audi Forum banner

1 - 5 of 5 Posts

·
Registered
2005 A6 Allroad
Joined
·
5 Posts
Discussion Starter #1
Hi, I have a 2005 Audi Allroad (C5) with RNS-E and steering wheel controls. I recently replaced the head unit with an aftermarket radio. Everything works great except that the instrument panel display is empty. The PRNDS gear display is there, but it doesn’t show anything else; like where the totter pressure would show up etc.

What could be wrong? I got the radio installed by an installer, and I don’t know that much about the internals of the car. Thank you.
 

·
Registered
Joined
·
6 Posts
Hi, I have a 2005 Audi Allroad (C5) with RNS-E and steering wheel controls. I recently replaced the head unit with an aftermarket radio. Everything works great except that the instrument panel display is empty. The PRNDS gear display is there, but it doesn’t show anything else; like where the totter pressure would show up etc.

What could be wrong? I got the radio installed by an installer, and I don’t know that much about the internals of the car. Thank you.
Hi,

It all depends of what aftermarket radio you installed. That cluster radio info like fm station for example goes via the can bus, and I assume that you dont have a canbus installed radio.

Some radio's allow a idatalink interface, iDatalink - Maestro - Home check your car and radio if supported with that interface all radio functions on steering wheel and cluster will work including OEM bluetooth
 

·
Registered
2005 A6 Allroad
Joined
·
5 Posts
Discussion Starter #3
I got a Pioneer AVIC-8600 NEX. The installation guys said that my car doesn’t allow iDatalink Maestro (even though the radio does). However, they did integrate the radio with the steering wheel controls.

All that works properly. But the instrument panel doesn’t show anything. For example, when you start the car it goes through the diagnostics and it’s supposed to give you some data on the display.

I don’t know much about the Can bus etc., so pardon my ignorance.
 
1 - 5 of 5 Posts
Top