Audi Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi Guys,

I wonder if anyone can help. Is there anyway to tell the RNS-E units apart if you don't trust the part number?

From my observations,

1) A6 unit - plastic fascia, wide at the top
2) A4 unit - plastiic fascia, with chrome strip at the bottom. Narrower than the A6 unit at the top
3) A3 unit - Rounded plastic fascia at the top.

Is this correct?

Thanks,
Ray
 

·
Registered
Joined
·
6,767 Posts
This is correct but you can change faceplates, so that's not the final answer. If you are able to connect the RNS-E to a car, you can connect with VAG-COM or similar to STG 56 and get the part number. And in Engineering mode (http://www.navplus.us/forum/viewtopic.php?t=71) you can see the serial number.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for that.
Hmmm...... If I have an A6 EU unitl, with the A4 faceplate, then if I recode the unit for a A4 EU unit, will it function as the A4 unit..... things like speed signal over CAN-Bus etc?

Thanks,
Ray
 

·
Registered
Joined
·
6,767 Posts
The A4 does not have a separate speed signal. It might be possible to get that signal from somewhere behind the instrument cluster but you would be on your own there. You may find an answere here http://www.nav-plus.com/instructions/a4b6.html but the cleaner way would be to get the correct faceplate...
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
My problem is that I think I have bought an A6 unit with an A4 faceplate.

This was for my A4. So, I can either make this work with my A4, by adding the speed signal from somewhere, or locate an A6 faceplate, then fit, and sell the unit on as the correct A6 unit.

Any ideas if it is possible to buy A6 face-plates?

Thanks,
Ray
 

·
Registered
Joined
·
515 Posts
why do you think it is an A6 unit with an A4 faceplate??.. have you connected a VAG-COM to it??..

i just installed my unit last wk.. the top lable was present, but the part number was mostly torn off and the A4 number was written in with marker..

i connected it to my A4 and it did not appear to be receiving the speed signal through CAN.. i was unsure if it was an A6 with an A4 faceplate or just a defective unit..

i connected my VAG-COM to it and saw that it was indeed a EU A4 unit (8E0 035 192 C).. but i also saw it was coded for an A6 (05xxxxx).. i changed the coding for an A4 (03xxxxx) and it works perfectly now with the speed signal over CAN..

i do not know if an A6 unit can receive speed over the CAN if it is coded for an A4.. but since you can change the coding on the units and my A4 unit did not receive speed over the CAN when coded for an A6, my GUESS is that the reverse is true -- and it is just a coding issue..

good luck..
 

·
Registered
Joined
·
3,759 Posts
You can recode an A6 unit to think it's an A4, so no need to sell it. I have the same thing an A6 with an A4 faceplate, I've ran it both ways in my A8 and it works. I can get speed pulses over can when in A4 mode and speed pulse from Gala in A6 mode.

Craig
 
1 - 8 of 8 Posts
Top