Audi Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
479 Posts
Discussion Starter · #1 ·
Before I fitted my RNS-E I'm sure my Instrument Dials were illuminated all the time, well with the ignition key at least.

You know the bits I mean, the white circular speed markings around the speedo, rev counter, fuel & temp gauges.

Now though, they only come on with the lights, I have played with my + & - buttons but they have no effect if the lights are off.

Am I going mad or is there a setting somewhere else that I need to set ?

Dave.
 

·
Registered
Joined
·
6,767 Posts
Device #17 channel 19:

?xxxx: Illumination Options

0 - Needle and Scala only active at 'Light on"
1 - Needle already active at 'Ignition on'
2 - Scale already active at 'Ignition on'
3 - Scala (2. Map) and Needle at "ignition on" active

source: http://en.openobd.org
 

·
Registered
Joined
·
6,767 Posts
Don't forget, if it's dark outside and the lights are off, the scala will dim down even if a 2 or 3 is coded here, just to remind you to turn on the lights.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #5 ·
Cheers, I'll bear that in mind.

That's a very usefull site, I've just been looking at some of the other codes listed, all sorts of things I can cock-up !

source: http://en.openobd.org

I like the idea of lowering & raising the roof at slow speeds, just like the latest model !

Dave.
 

·
Premium Member
Joined
·
11,350 Posts
AudiA4B6US said:
It's even better if you switch to the German part, but hard to understand if you translate it online.
There's masses more information in the German part, well worth the effort of translating it for yourself.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #8 ·
AudiA4B6US said:
Device #17 channel 19:

?xxxx: Illumination Options

0 - Needle and Scala only active at 'Light on"
1 - Needle already active at 'Ignition on'
2 - Scale already active at 'Ignition on'
3 - Scala (2. Map) and Needle at "ignition on" active

source: http://en.openobd.org
Great, this worked a treat and I note the comments about it dimming when it starts to get dark.

I was looking on that site re the comfort window open / closing via remote, but paused as I don't think I have enough info yet.

My A4 Cab currently has a value of 204, as opposed to the German default of 095 or US of 075 ?
I can already open & close the windows and roof using the ignition key, so I’m wondering if I might need to subtract from the value 204, rather than add to it ???

Select 46 (Comfort System)
Adaptation -> Function 10
-> Channel 62 (Comfort Function)
+001 - Comfort closing via remote for window regulators (not USA)
+002 - Comfort opening via remote for window regulators (not USA)
+004 - Comfort closing via lock cylinder for window regulators
+008 - Comfort opening via lock cylinder for window regulators
+016 - Comfort closing via remote for sunroof (not USA)
+032 - Comfort opening via remote for sunroof (not realized)
+064 - Comfort closing via lock cylinder for sunroof
+128 - Comfort opening via lock cylinder for sunroof (not realized)

Anyone got any ideas

Also I can't now find the reference to raising the roof at slow speeds that I saw before ???

Dave.
 

·
Premium Member
Joined
·
11,350 Posts
Dave.G6HNI said:
My A4 Cab currently has a value of 204, as opposed to the German default of 095 or US of 075 ?
I can already open & close the windows and roof using the ignition key, so I’m wondering if I might need to subtract from the value 204, rather than add to it ???

Select 46 (Comfort System)
Adaptation -> Function 10
-> Channel 62 (Comfort Function)
+001 - Comfort closing via remote for window regulators (not USA)
+002 - Comfort opening via remote for window regulators (not USA)
+004 - Comfort closing via lock cylinder for window regulators
+008 - Comfort opening via lock cylinder for window regulators
+016 - Comfort closing via remote for sunroof (not USA)
+032 - Comfort opening via remote for sunroof (not realized)
+064 - Comfort closing via lock cylinder for sunroof
+128 - Comfort opening via lock cylinder for sunroof (not realized)

Also I can't now find the reference to raising the roof at slow speeds that I saw before ???

Dave.
It's a simple piece of binary arithmetic (well simple for programmers like me!).

If you subtract values then you will STOP features that currently work from working!

What you should do is:

- work out which bits are set with your present value. In your case that's 204 (= 128 + 64 + 8 + 4)

- translate that into what should currently work. In your case that means: 128 does nothing, 64 = sunroof close via key, 8 = window open via key, 4 = window close via key (which fits exactly with what you say!).

- work out the correct value for what you want to work. IMHO I can't see any reason to have any value other than 95 (= 64 + 16 + 8 + 4 + 2 + 1) because this makes everything that can work, work! (windows open & close via key and remote, sunroof close via key & remote. NOTE sunroof open via key & remote even if coded DOESN'T WORK!)

- change the adaptation channel value.

- check using key and remote (remember with the remote you have to press AND HOLD the button until the operation finishes).
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #11 ·
PetrolDave said:
It's a simple piece of binary arithmetic (well simple for programmers like me!).
There are only 10 types of people is this world.

Those that understand Binary...... and those that don't ! :!: :lol:
 

·
Registered
Joined
·
235 Posts
Hey guys, what is the " Comfort system" ? Does a 00 audi a6 have whatever that is?
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #13 ·
dmollico said:
Hey guys, what is the " Comfort system" ? Does a 00 audi a6 have whatever that is?
Sorry no idea personally, but I'm sure someone who knows will be along soon.

PetrolDave - that did not work for me - I tried 95 and also 255, both ways I can open/close windows and roof from the door lock, but not from the key fob.

Just to confirm I'm doing it right.....

From locked press and hold the unlock button on my key fob, the doors unlock but windows stay up
From locked press once, twice and hold the unlock button on my key fob, the doors unlock but windows and roof stay up.

Whereas if I use the cylinder lock....

From locked turn and hold to the unlock position, the doors unlock and windows go down.
From locked turn once, twice and hold to the unlock position, the doors unlock and windows go part down and the roof opens.

And it gets worse :?: :?: :?:
I noticed that my instrument scala light are not comming on again, although the needles are.

I checked the coding more carefully and it is still as it was 31300, but this does not seem to tally ?
Bit 3 (DIS) is 3 & the only listed option are 0, 1 & 2 ???

Also I tried 21300 and it would not accept it, so I guess I must be doing something wrong.

When I first checked the cpde it was already 31300 so I just save it again and the dials illuminated, so I guessed it just needed the 2nd mapping, but why has it reverted back to off ???

Really confused.
 

·
Registered
Joined
·
1,624 Posts
You cant just change the adaptation channel to get your window recode to work. You also have to enable it by adding 64 to your coding value (07-recode) of the 46-comfort module.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #15 ·
NSX JR said:
You cant just change the adaptation channel to get your window recode to work. You also have to enable it by adding 64 to your coding value (07-recode) of the 46-comfort module.
Right, found that, OK I will give it another go in the morning, thanks.

Any ideas regarding my instrument gauge coding issues ?

Dave.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #16 ·
NSX JR said:
You cant just change the adaptation channel to get your window recode to work. You also have to enable it by adding 64 to your coding value (07-recode) of the 46-comfort module.
Right, I've had some success having added 64 to my recode value of 06795 = 06859

When I press and hold the unlock button the windows open a few inches, but if I then press & hold the lock button, the windows do not close. They still do from the key though.

Also the roof still does not open from the remote, but still does from the key.

The code I am using for adaptation 62 was 204 and is now 255.

My scalar light are working again this morning, so maybe I need to leave it another day and try it again ?

I did find 2 faults which I cleared and have not returned ???

-------------------------------------------------------------------------------
Address 26: Auto Roof
Part No: 8H0 959 255
Component: VSG B6 CABRIO 6389

1 Fault Found:
00532 - Supply Voltage B+
002 - Lower Limit Exceeded - Intermittent

-------------------------------------------------------------------------------
Address 46: Central Conv.
Part No: 8H0 959 433 F
Component: Komfortgerát T3B 3320
Coding: 06859
Shop #: WSC 00672

Part No: 8H2959802B
Component: Tõrsteuer.FS BRM 3020

Part No: 8H2959801B
Component: Tõrsteuer.BF BRM 3020

Part No: 8H0959801A
Component: Tõrsteuer.HL BRM 0002

Part No: 8H0959802A
Component: Tõrsteuer.HR BRM 0002

1 Fault Found:
00955 - Key 1
35-10 - - - Intermittent

-------------------------------------------------------------------------------

Dave
 

·
Registered
Joined
·
1,624 Posts
The roof will never open from the remote, it just does not work. I somehow missed the fact that you had a cab. I dont think the window recode works at all on the cab so all your efforts may be for naught.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #18 ·
OK, thanks for the update, I will give it 24hrs and see if there is any improvements, otherwise I will call it a day.

Although I do now have the ability to open the windows a few inches from the remote that I did not have before.

Dave.
 

·
Registered
Joined
·
479 Posts
Discussion Starter · #19 ·
Comfort Control from Keyfob not available on Cabriolet ?

Well I've left it a couple of days and I still can not close my windows from the remote, so I guess that feature is just not available on the cabriolet. (although they do open a few inches via remote). :cry:

Also, although my scalar light now come on with the ignition, this morning (7am) when it was too light to put side lights on, but not full sun, I could not see the scalar lights at all.

If this is the automated dimming effect at work, then I would really like to adjust it, because just when I could use the extra illumination to see the dials clearly it appears the illumination is not available ???

I've just been out to have a look now and on they come, where is the photcell / sensor located maybe it is adjustable ???

Dave.
 

·
Premium Member
Joined
·
11,350 Posts
Re: Comfort Control from Keyfob not available on Cabriolet ?

Dave.G6HNI said:
Also, although my scalar light now come on with the ignition, this morning (7am) when it was too light to put side lights on, but not full sun, I could not see the scalar lights at all.

If this is the automated dimming effect at work, then I would really like to adjust it, because just when I could use the extra illumination to see the dials clearly it appears the illumination is not available ???
That's how it works. When it's dark enough for you to need to put the lights on the instruments are darkened so you can't read them either - in an attempt to inform you that you need to put the lights on.

I don't know of any way to change/adjust this behaviour.
 
1 - 20 of 20 Posts
Top