Audi Forum banner

421 - 440 of 456 Posts

·
Registered
Joined
·
595 Posts
in the old tail light you have 2 bulbs which both light at 50% intensity when low beam is ON and at 100% when you hit the brakes. the facelift tail light has separate circuits for sidelight and brakes so requires separate signals on the wires. if you connect the led taillights, the old controller will output 7 volts on both wires so side light led and brake light will be ON all the times at half intensity and when you hit brakes will go to 100%. this is hardly visible in sun light. i guess the adapter module will "listen" to the voltage supplied by the controller and will issue separate voltage on each wire to the tail light for their respective function. there are now errors in DIS when you connect the led tail lights with old controller but when ignition is ON, the controller issues on all circuits a 5 volts pulse every 30 seconds to check bulb integrity which will result in a short flash in the led tail light. somebody driving behind you will think that you press brakes and hazard warning lights briefly every 30 seconds which is anoying and in many countries illegal as it is considered a malfunction of the car's lighting system.
 

·
Registered
Joined
·
35 Posts
Adrian. You are the best. always. R E S P E C T
 

·
Registered
Joined
·
21 Posts
I did my tail lights with out using any adaptors or changing the module.
I left the original bulbs for the tail lights connected but hidden to stop any errors on the dash. I connected the new led tail lights through relays, you pick up the brake light power from the centre led brake light (12V) and the parking lights from the licence plate lights(12V), the indicators you tap into the current indicators.
The only reason to run the relays is to stop the 30 sec pulse.
I have had mine connected like that for 2 years now with out any problems at all.
 

·
Registered
Joined
·
35 Posts
Thx Xlr8it

This is good information. Would it be painless for you to sketch a wiring diagram? Would be a great help to this thread.

Also what relays (specs/power) that you used?

Are your lights working with full functionality? I.e half brightness full brightness etc
 

·
Registered
Joined
·
19 Posts
Hi everybody.

I will upgrade my Q7 2007 Bi Xenon AFS to Tri Xenon LED AFS and have these parts.

4L0 941 029 AD – Adaptive BiXenon Lamp – Left
4L0 941 030 AD – Adaptive BiXenon Lamp – Right
4L0953041E–SLine–Left



4L0 953 042 E – SLine – Right
4L0 941 613 A – Headlamp Mounting Tray, Left
4L0 941 614 A – Headlamp Mounting Tray, Right
4L0 941 717 – Vent Hose, Left
4L0 941 718 – Vent Hose, Right
000 979 009 – Trigger Wire (2x needed)
4F0 910 279 Q – J519 Onboard Control Module – w/electric steering column
Can You confirm that this is all I need to complete this upgrade, and it will work perfectly if I follow this DIY? http://www.oemplus.com/DIY/Q7_LED_Headlamps.pdf

Stephan
 

·
Registered
Joined
·
35 Posts
Hi Stephan,

Yes and you would have to get the component protection removed from the new J519 unit from an Audi dealer after the retrofit. Iam not sure if bixenon to trixenon headlight harnesses are available but if they do then It is also suggested that you use wiring harness from kufatec or wibutec etc instead of trigger wires as it is difficult to get the new wires in the headlight harness without proper tools.

i
Hi everybody.

I will upgrade my Q7 2007 Bi Xenon AFS to Tri Xenon LED AFS and have these parts.

4L0 941 029 AD – Adaptive BiXenon Lamp – Left
4L0 941 030 AD – Adaptive BiXenon Lamp – Right
4L0953041E–SLine–Left



4L0 953 042 E – SLine – Right
4L0 941 613 A – Headlamp Mounting Tray, Left
4L0 941 614 A – Headlamp Mounting Tray, Right
4L0 941 717 – Vent Hose, Left
4L0 941 718 – Vent Hose, Right
000 979 009 – Trigger Wire (2x needed)
4F0 910 279 Q – J519 Onboard Control Module – w/electric steering column
Can You confirm that this is all I need to complete this upgrade, and it will work perfectly if I follow this DIY? http://www.oemplus.com/DIY/Q7_LED_Headlamps.pdf

Stephan
 

·
Registered
Joined
·
35 Posts
Yes Stephan, this is the one. In its picture, you will notice a two pin male harness that will simply go to the parking/side light harness of the respective turn signal.

Manually you have to take the +ive wire of the parking/side light harness of the turn signal and get that to go into Pin 12 of the 14-Pin Headlight harness. Pls have it double checked also as my conversion was from halogen to Bixenon.
 

·
Registered
Joined
·
35 Posts
the normal led blinker has 1 extra led compared to s-line, the body is the same
I fitted the normal led blinker in my retrofit to my normal 2007 Q7 and had to cut the bumper for that 1 extra led. Did this mean hat the Sline Blinker would have fit without the cutting??
 

·
Registered
Joined
·
19 Posts
Which functions will not work before you move the CP? Mine says Headlight range control defective, Trailer left rear light, Trailer right rear light, Adaptive light defective and I do have adaptive headlights like before the upgrade.
Will these disappear after the removal of the CP?

Stephan
 

·
Registered
Joined
·
19 Posts
Ok. I ran into some problems. My LEDs does not light up. I have changed the headlights fron Bi xenon adaptive to tri Xenon LED adaptive. I used this harness adapter http://www.kufatec.de/shop/en/Audi/Q7-4L/Xenon/HID-Headlights-with-LED-DRL-Adapter-Audi-Q7-4L2?action_ms=1 I changed the J519 for
4F0 910 279 Q and recoded it 0033121. I get the these errors in the dash: Headlight range control defective, Trailer left rear light, Trailer right rear light, Adaptive light defective. There are also two headlight bulb errors. Have I missed anything?

Stephan
 

·
Registered
Joined
·
19 Posts
Ok, so far so good. I managed to get rid of the Headlight range control defective and Adaptive light defective errors. I still have no light in the LEDs. I also still get these two faults in the display: left driver light bulb, right driver light bulb, Trailer left rear light, Trailer right rear light. Any suggestions???

Stephan
 

·
Registered
Joined
·
19 Posts
Hi All. I did this mod on the new J519:http://audiforum.us/threads/facelift-2010-retrofit.11477/page-5 with the bridging like this: T12B PIN9 to T32C PIN15, T12B PIN10 to T32C PIN3. Everything is working like its supposed to exept the left side of the turn indicators. There is a solid light in the front turn signal (Bumper) and no turn light in the mirror. If I bridge T12B PIN 9 to T32C PIN 14, the same happens to the right side. So the bridging must be wrong for the left side. Can you tell me the right PIN numbers to bridge for the left side?
 

·
Registered
Joined
·
19 Posts
FIXED!!!! I ended up bridging T12B PIN 9 to T32C PIN 15 and T12B PIN 10 to T32C PIN 4. All works as it is supposed to. Thank you everyone for your help.
 
421 - 440 of 456 Posts
Top