Audi Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
My DIS screen works and sometimes doesnt work.. i did the following...

The vag procedure is as follows for the DIS.

Instrument Block>Adaptation 07>Channel 62>Change value shown to 21.

Save and exit and wait 'til your ECU recognizes RNS-E could take 10 seconds or 10 hours.

i tried it and it didnt work... so this morning i started my car and it worked... i was happy, but now after work it doesnt work... wut is going on ?

i think this might be my reason but can anyone confirm this ...

The main problem is I'm unable to change coding from 8 to 1 because i don't have steering wheel control, cd changer, or even tv tuner. There are 4 trouble codes in RNS, it includes all of the above... non exist units un-communicate and missing coding wiring.. any help would be much much appreciated


And the cable I'm using is HEX-CAN.



and then back to this...



WHY WHY WHY !!!

and in an unrelated note ... my mp3s all work but how come when i go to just list track name instead of file name .. it does this...


like some of them have the folder in front of them and some don't.. i wanna see just the name of the song and not the folder and the song... and also i read that once i press the cd/tv button and hold RETURN.. i can list my files like thumbnails. does anybody have a screen shot of this... i cant get this to work, am i doing something wrong...??????????

TIA, u guys have always been helpful

james


[/img][flash][/flash]
 

·
Registered
Joined
·
209 Posts
Turn the compass on from the NAV setup and the DIS will always work, but it will also always go to compass/street name mode if you are not usig the navigation instead of telling you your MPG, etc. Of course you can toggle back to the MPG etc with the button on the stalk.
 

·
Registered
Joined
·
51 Posts
HX_Guy said:
Turn the compass on from the NAV setup and the DIS will always work, but it will also always go to compass/street name mode if you are not usig the navigation instead of telling you your MPG, etc. Of course you can toggle back to the MPG etc with the button on the stalk.
is that even an option? i was in the nav setup earlier today and i dont rememebr seeing that...

- usually to make the DIS bring back the nav commands you have to turn off the nav unit and then on quickly a single time and click the stalk button to switch back to the nav and it'll work. thats all i have to do, but most of the time it works on its own.
 

·
Registered
Joined
·
6,767 Posts
Ok, here's what's known so far about the red DIS in a B6 A4:

After coding the instrument cluster to +4 in channel 62, remove the fuse for the cluster or wait a couple of hours. The cluster needs to reset in order to accept information from the navigation unit.

If compass is turned on (press NAV then SETUP, scroll down and check Compass) the the DIS will always show the direction and street your are on. if you are in active route guidance it will show the direction and distance as well.

If compass is turned off and route guidance is activated while the car is not moving, you may need to power off the RNS-E briefly and turn it back on. It has been reported that if route guidance is activated while the car is mobving then the directions show up immediatly on the DIS.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #8 ·
just as an update, setting the compass to on still doesnt work, well sometimes it works and sometimes it doesn't, is my coding rite ? or should i just unplug my cluster and let it program itself... i find it really useful with information on the cluster because it tells me what road i am currently on instead of looking at the rns... any help would be much appreciated...

james
 

·
Registered
Joined
·
45 Posts
My observations:
I have red DIS....

if NAV programmed BEFORE starting ignition, DIS info does not display.

if NAV programmed AFTER starting ignition & cluster working - DIS works perfectly
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #10 ·
my experiance so far is similar, sometimes i have DIS and sometimes i don't... if i don't i simply turn my RNS off and turn it back on and it reappears... but the question is WHY, why can't it just stay on with the compass... my NAV==>setup/ compass is checked at all times... also another annoying thing is once my gf opens my passenger door if i have my DIS displayed with compass directions it will immediatly go away and go back to my old dis with the miles left till fill up and park, neutral, drive, etc... why is this... i just want that dis to display directions at all times... does n e body know wut i did wrong ..... thanks for all ur input thus far in trying to help me out... all ideas are welcome.. tia
 

·
Registered
Joined
·
6,767 Posts
This issue has been mentioned in several topics here on the forum, the root cause is the firmware in the instrument cluster but you cannot upgrade the firmware in the cluster. The only way to solve this is to install a new cluster with a color DIS.
 

·
Registered
Joined
·
77 Posts
ejc2008 said:
yeah if u turn ur navi on before it wont send signal to dis ....
EJC is right, you need to hit the accept screen on the Navi AFTER all the airbag, clutch, etc warning lights have cleared. It looks like the Can-Bus message from the Navi is not persisted in the DIS. I had the same problem, until I installed the Wiper Stalk with the buttons and re-coded my steering wheel.

Cheers,

:: Chuck
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #14 ·
oh i c... so ill just press the accept screen a bit later... i will give that a try, im asking the dealer how much a color dis is.. if the price is within reason i will hold off on coilovers and get color dis.. i am super impressed with the rns !!! thanks guys
 

·
Premium Member
Joined
·
11,350 Posts
batmiterns said:
im asking the dealer how much a color dis is.. if the price is within reason i will hold off on coilovers and get color dis..
Expect not to get much change from $1000.
 

·
Registered
Joined
·
77 Posts
I got my Color DIS for $350 from a guy off this board. Otherwise, expect to pay about $575 for DIS, another $200 for the Core Charge and $200 for installation. So at the end of the day about $1000.

Cheers,

:: Chuck
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #19 ·
nope damn, but its my only option to get my DIS to work properly! damn why why why ! does n e one think if i unplug my cluster for say an hour or so it will work properly ? ? ? ? ?
 

·
Premium Member
Joined
·
11,350 Posts
batmiterns said:
nope damn, but its my only option to get my DIS to work properly! damn why why why ! does n e one think if i unplug my cluster for say an hour or so it will work properly ? ? ? ? ?
Nope.

That's just how red DIS's work on the A4 B6/B7.

They weren't designed to work with the RNS-E, and Audi sure as heck ain't going to change that - because they only sell the RNS-E in cars with the color DIS.
 
1 - 20 of 28 Posts
Top