Audi Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have bought an VAG-COM tool to connect to my car. It was delivered with an rs232 connector, because my laptop does not have an rs232 port anymore if have used an adapter (rs232 to usb). Connecting seems to work (led turn red just after connecting cable to car). In the options screen I have tested the connection an it says : com port stauts ok and interface found (both leds will flash green and red while connecting).

But when I would like to connect in the OBD-II it finds the interface but a false startbit. Therefor it will not connect.

Does anyone have an idea how to solve this issue because Ross-tech is giving no support because of the adapter I have used.

BTW my car is an A4 Avant B5 (with allready the RNS-E installed)
 

·
Registered
Joined
·
515 Posts
from ross-tech's wedsite

http://ross-tech.com/vag-com/interfaces.html

they say..
Add-on USB<->Serial Converters are not supported!
perhaps it when you 'test' the interface it sees it, but the communication is not good enough, fast enough, or clean enough to work with the car??..

good luck..
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
I was aware that Ross-Tech was not givong support, therefor my post on this topic.

In the meantime I have tried it on and on. I managed to connect to some options (f.i. Engine, HVAC).

So the connection is there but I guess not stable.

Someone else any ideas?
 

·
Registered
Joined
·
6,767 Posts
I would recommend to find someone with a real VAG-COM and confirm it's an issue with the cable ot the USB-Serial adapter. I have seen people spending days trying to fix an issue just because one little thing didn't fit right.

There are reports that some high end USB-Serial adapters work just fine with the original VAG-COM cable. But the last release of the VAG-COM software which works with non-VAG-COM cables is so outdated by now, it could be everything.

Also, since you did install the unit in a B5, did you connect the K-line properly? Without k-line you wouldn't be able to access the RNS-E at all.
 

·
Super Moderator
Joined
·
11,350 Posts
Placemaster said:
I was aware that Ross-Tech was not givong support, therefore my post on this topic.
So the connection is there but I guess not stable.
The very reasion that Ross-Tech don't support using a USB to serial converter is that many (most?) are not stable.

Perhaps if you post what model of laptop you have and what usb to serial converter, someone here MAY have solved the problem - there isn't a generic solution. Or you may just have a setup that won't work reliably.

I heeded Ross-Tech's comments and bought a laptop with a serial port (Dell Inspiron 510m) to match the HEX-COM cable I already had. Means I can use the latest version of VAG-COM (504.1).
 
1 - 5 of 5 Posts
Top