Audi Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Does anyone has experience pairing Sonyerisson phones on the Audi BT /RNS-E? My phone (M600i) pairs with the kit, however within a minute it gets disconnected. After that I can't pair the phone again, I need to reboot the phone.

What data is the Audi carkit trying to get from the phone? I understand the carkit also downloads addressbook info and more from the phone?
I just need the handsfree!

Many thanks

Ralph
 

·
Premium Member
Joined
·
11,350 Posts
I had this problem with my SE K610i. Incidentally, I didn't need to reboot the phone just disabling and re-enabling Bluetooth was enough.

The Bluetooth kit is trying to download your contacts and the dialled/missed/received calls lists from your phone.

On craigyb's suggestion I checked for phonebook entries that were "Other" (not "Home", "Work" or "Mobile") since they are known to cause a problem. I changed all of them and tried again - same problem.

So I copied all my contacts to the Memory Stick and cleared the contacts list - still the same problem!

So I changed the phone Bluetooth name to something shorter - originally I had changed it to a 13 character name. Success!

Copied the contacts back from the Memory Stick and all OK.

So - check for contacts with "Other" entries AND keep the phone name short.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks for the suggestions PetrolDave!

If the BT kit is trying to download all address book data, it probably also tries attached pics for a contact?

I will start cleaning the address book now :( and will try first thing tomorrow and let you know if it works for me.

Thanks again!

Ralph
 

·
Premium Member
Joined
·
11,350 Posts
rdirkse said:
If the BT kit is trying to download all address book data, it probably also tries attached pics for a contact?
Unfortunately it doesn't download the pics - or any information other than the phone numbers (no addresses, email, birthdays, etc.)

It would be really cool for the contact pic to appear on the RNS-E display! - maybe that's another suggestion for the Nav Hacks thread?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
It works!!!! I fisrt removed all extra data from the phone, and it still got disconnected but now after about 5 minutes.

I decided to backup the addressbook onto a memory card and cleared the complete addressbook from the phone. That fixed it. It is now paired with the Audi BT kit and not disconnecting .... at least not for the hour I tested it!

I will now add new entries to te address book by hand to see where it goes wrong. So far I have already stored upto 20 entries and have no problems!

Thanks a million for all the help!!!

Ralph
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
I now have problems receiving calls. It rings twice and then gets disconnected from the carkit. Outgoing calls are working fine.

Does anyone has some ideas tips?

Thanks again

Ralph
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
I think I finally figured it out!

I still had disconnections from time to time even without any changes
made in the address book. Also receiving calls resulted in a
disconnect.

The solution here is to NOT use the phones address book at all.
I copied all contact to the SIM card and erased the phones address book
The BT kit updates it's address book showing contacts from SIM icons.

After that all works perfect!

Just to let everybody know with SE M600i phone:)

Thanks

Ralph
 

·
Registered
Joined
·
28 Posts
SE M600i

just to let you know that I have no problem at all and my all my contact in my phonebook and sim can be access.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #9 ·
Hi veteq,

Are you using SE M600i on Audi UHV 345?

Can you check under "system information" on your phone for versions?

I have the following:

Phone: CXC162037 R3A00
Bluetooth: CXC1620S8 R3A01
Organizer: CXC162011/1 R3A03
CDA: CDA162011/1 R3A03

Thanks

Ralph
 

·
Registered
Joined
·
28 Posts
I am using Audi UHV 8602


phone: CXC162037 R9A002
bluetooth: CXC 162058 R3A01
organizer: CXC 162071 R4C01
cda: CDA 162011/2 R4C01
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #11 ·
Looks like the BT version is the same.
Let me check if my phone needs an update...

As for the carkit, not sure how that works.
Just got a new A4 with an RNS-E+carkit.
The phone shows it as UHV 345 which differs from yours.
Maybe that's the problem.

Thanks anyway

Ralph
 

·
Registered
Joined
·
28 Posts
Try updating the phone... I had the same problem before updating.... the bluetooth disconnect after a few seconds, the phone end the call after two rings and no phonebook. Now I don't have any problem at all
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #14 ·
Hi Veteq,

I had the phone upgraded and it now has the same versions as yours.
I tried it today using the address book and indeed it works now!! COOL!!

Tomorrow I will test if I can receive calls too.

Thanks for your tips and suggestions.

Ralph
 

·
Registered
Joined
·
28 Posts
Good to hear that it works... :D . I believe most phone will work with the Audi bluetooth. All you have to do is try updating the phone first.
 

·
Premium Member
Joined
·
11,350 Posts
veteq said:
I believe most phone will work with the Audi bluetooth.
It depends what you mean by "work".

No Symbian 60 based Nokia will be able to synchronise phonebook and call lists - and that same restriction applies to many other phones as well.

Most, but not all, phones will allow hands-free operation.

See the compatibility thread in this forum for details of our current shared knowledge regarding which phone models work - fully or partially.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top