Audi Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
i have a 06 A3 with bose and just got my RNS-E installed like a week ago, it works perfect and have info shown on DIS. the question is, i thought that the VAG is needed to set so to display info on the DIS, but i didn't set anything and it still displays fine for me, so what actually change if i change the VAG?
 

·
Registered
Joined
·
1,624 Posts
season007 said:
i have a 06 A3 with bose and just got my RNS-E installed like a week ago, it works perfect and have info shown on DIS. the question is, i thought that the VAG is needed to set so to display info on the DIS, but i didn't set anything and it still displays fine for me, so what actually change if i change the VAG?
I think in the new A3 there is nothing to code for the cluster... it is all in the CAN gateway and it seems yours is working fine so no need to mess with it.
 

·
Registered
Joined
·
117 Posts
NSX JR said:
season007 said:
i have a 06 A3 with bose and just got my RNS-E installed like a week ago, it works perfect and have info shown on DIS. the question is, i thought that the VAG is needed to set so to display info on the DIS, but i didn't set anything and it still displays fine for me, so what actually change if i change the VAG?
I think in the new A3 there is nothing to code for the cluster... it is all in the CAN gateway and it seems yours is working fine so no need to mess with it.
I posed the same question today about my A3.

Craig answered in this forum that this isn't necessary for the A3, don't need to vag anything, it's in the CAN.
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #4 ·
ergh so nice thanks a lot
i don't even have to temporary stop problem in DIS so i am real happy with it :)
thanks again for great support and unit from HAGGIE :lol:
 

·
Registered
Joined
·
21 Posts
I also have just installed a RNS-E in my 2006 A3 (see my other posts) but I do not get any NAV information in my DIS just radio/mp3 info. I am a bit confused as before (PetrolDave advised that I would need to get the adaption value of the instruments in my car changed by VAGcom) I thought that VAGcomming my car would get the DIS to work is this not correct? Thanks.
 

·
Registered
Joined
·
3,759 Posts
A3's are programmed from the CAN gate way module 19 in VAG.

When I add an RNS-E or telephone module to an A3 I always programme the can gateway to tell the car what modules it has installed.

It uses the long coding to flip bits as to what modules are installed in your car.

VAG com 510 Beta onwards contains a long coding helper, simply run that and tick the boxes you require. Save the new number back to long coding and your done.

I will try and get a screen shot next time I do an A3

Craig
 

·
Premium Member
Joined
·
11,350 Posts
mactrack said:
I am a bit confused as before (PetrolDave advised that I would need to get the adaption value of the instruments in my car changed by VAGcom) I thought that VAGcomming my car would get the DIS to work is this not correct?
Adaptation value in instruments is an A4 thing, it's not needed for an A3.

My bad.

Follow craigyb's advice - he's fitted RNS-E's into several A3's, I've only done an A4.
 

·
Registered
Joined
·
21 Posts
No worries and thanks for all the replies. As I will not be doing the VAGcom work myself all I really wanted to know was whether using VAGcom would solve the DIS problem (which it will). The guys I hope to use for this are www.satnavsystems.com and I am assuming their engineer will know what coding needs to be done because I have absolutely no idea what a can gateway is!
 

·
Registered
Joined
·
3,759 Posts
I wouldn't count on it...
 

·
Registered
Joined
·
21 Posts
OK further update. I go shopping this morning and when I get back to my car and start it I got "NW" in the DIS (I think that I've got some sort of error message) but as I move off and turn around it becomes clear that it is a directional compass. I start the route guidance home and lo and behold my DIS now shows directions and street names etc.

I have read other posts that this delayed functioning of the DIS is not uncommon after retrofitting a RNS-E. I also have the MFSW (version B) and I have downloaded the RNS-E pdf manual and it appears that the "mode" and talk" buttons do not have any function (my DIS does display "NO FUNCT" when they are pressed). Do these buttons only work with a telephone system installed?

I would be grateful if someone could confirm that the MFSW only controls volume and radio/mp3 station/track (unless SDS is enabled) and therefore there is nothing else for me to do as far as the installation is concerned (i.e. no VAGcom work required so I can save myself a few quid). Thanks.
 

·
Registered
Joined
·
6,767 Posts
mactrack said:
OK further update. I go shopping this morning and when I get back to my car and start it I got "NW" in the DIS (I think that I've got some sort of error message) but as I move off and turn around it becomes clear that it is a directional compass. I start the route guidance home and lo and behold my DIS now shows directions and street names etc.

I have read other posts that this delayed functioning of the DIS is not uncommon after retrofitting a RNS-E. I also have the MFSW (version B) and I have downloaded the RNS-E pdf manual and it appears that the "mode" and talk" buttons do not have any function (my DIS does display "NO FUNCT" when they are pressed). Do these buttons only work with a telephone system installed?

I would be grateful if someone could confirm that the MFSW only controls volume and radio/mp3 station/track (unless SDS is enabled) and therefore there is nothing else for me to do as far as the installation is concerned (i.e. no VAGcom work required so I can save myself a few quid). Thanks.
The NW can be removed by turning off Compass in the RNS-E setup. And you are correct, the MFSW does nothing else but volume up/down and next/prev track if you have neither the RNS-E HIGH with SDS nor the OEM BT phone interface installed.
 

·
Registered
Joined
·
3,759 Posts
You will find that the cluster will work without a VAG com coding of the can gateway, but your can gateway will have error codes, "Incorrectly coded module" as it can see modules it is not programmed for.
 
1 - 14 of 14 Posts
Top