Audi Forum banner

CD Changer not detected (BlitzSafe)

2305 Views 8 Replies 5 Participants Last post by  S4_Ranger
Hi all, just installed my Nav-D and it works great, all systems are go. Except that when it comes on it says 'No CD Changer detected'.

So that tells me the unit is coded properly, its just not seeing my CD Changer.

I don't have a CD Changer of course, I am using a BLitzSafe adapter for my iPod.

Any tips on why its not seeing it?

1 - 4 of 9 Posts
Blitz is in the 13 pin trunk connector. I am assuming the unit is VAG'd since its 'looking' for a CD-Changer.

Would it try to find it if it was not VAG'd properly?

I tried connect pin 10 of the 10 pin to pin 10 of the 20 pin to ground the CD-Changer with no impact. Very frustrating, I miss me ipod:)


TeddyBGame said:
is the blitzsafe mounted behind the Nav+ or in the trunk...via the round 13 pin adaptor.

If behind HU....then make sure the ground wire is grounded...and double check it.

If in trunk.....then make sure your Nav+ is vag'd for a CD changer; factory settings should already have it set that way...but you can never be too sure.

Check these...and let us/me know.

No, blitz is fine, been using it for years and when I swap my Symphony back in it works great.

I went through the pins last night and everything looked fine. I'll run them again this weekend and see what happens.

Thanks Ted!

TeddyBGame said:
I would check all the ground points behind the Nav+. Especially, those that support the CD changer (pins 13-20 in the 20 pin connector).

Try another Blitzsafe see if you have a faulty one.

You can probably buy one at and return it for a full refund...I think they are $75+.

Good luck!
This weekend i went out and hooked up an actual CD-Changer.

Worked like a champ.

Then, while it was playing, I'd disconnect it and connect my Blitzsafe. That would make the ipod work. Power down the car and I was back to square one.

Is that still a ground situation?

Which pin needed ground? Annoyed Wife's Who Are Tired Of A Car In Pieces want to know ;)


Marc911 said:
I had the same issue and it was a ground.
1 - 4 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.