Audi Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Well, it was a merry Christmas for me as my wife bought me the 2007 Nav disc. I was/am very excited to get rid of the nag screen.

I made an update CD and went out to update my unit. However, when I tried to connect to the RNS-E via VAG-COM it can't stay connected long enough to get anything done. It will connect for about 1 second, then disconnect. The cycle repeats until it finally gives up and says "too many errors communicating."

I'm using VAG-COM 607.3 with a HEX-CAN USB. I can connect to other modules just fine (recoded my tip trans at the same time, for example.)

I fear I may have a loose wire or something in my harness, but the RNS-E works flawlessly which to me seems to indicate it should be OK (e.g. it switches to night mode when the headlights come on, etc.)

I'd appreciate any help you might have. Given the very tight fit in the S6, I hope I don't have to pull the RNS-E out of the car to fix this.
 

·
Registered
Joined
·
6,767 Posts
In normal operation you wouldn't notice a missing/intermittend problem with the K line. I'm afraid pulling the RNS-E is the only way to check/confirm if you have no issue connecting to other modules in your car.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #3 ·
OK, thanks. That's pretty much what I expected, but I was hoping against hope there was an alternative. So it's the K-line connection that I should check for a bad connection when troubleshooting the VAG connection? I guess I could bypass the PnP harness for just the K-line just to get the upgrade done if I need to.
 

·
Premium Member
Joined
·
11,350 Posts
ktkemp said:
So it's the K-line connection that I should check for a bad connection when troubleshooting the VAG connection?
Yes that's correct.

The K-line is a serial communications line used only for diagnostics.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #6 ·
I have a European RNS-E installed in my US S6 that has been partially converted to use the US software. This half-way conversion was common a year ago when I purchased and installed my RNS-E.

Subsequently AudiA4B6US (I think) figured out how to fully convert units to use software from other regions. I need to use VAG-COM to force the RNS-E to accept an interim software update in order to complete the conversion to US software before I will be able to just load new software by inserting the new disc.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top