Audi Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6,767 Posts
Discussion Starter #1
Ok, I thought that would be easy and straight forward after reading all the BT success stories here but it seems it isn't.

My setup: US 2004 A4 B6, US BT module 8P0 862 335B, US RNS-E 8E0 035 192 E (SW 0110), VAG-COM Hex-CAN USB 5.10 beta.

My VAG-COM talks to the instrument cluster on #17 and to the RNS-E on #56, RNS-E is coded for 6 (Telematics) and tells me the phone is not connected. If I unplug the phone interface the RNS-E tells me the interface is not installed. So far so good.

However, I seem to be unable to talk with VAG-COM to the phone interface on #77. The RNS-E sees whether it's connected or not and since its not coded yet I guess this happens over CAN. I thought with the new VAG-COM 5.10, it would be easy to connect to a brand new phone interface even though it's not coded for K-wire HU yet.

Am I missing something? Any hint would be appreciated.
 

·
Registered
Joined
·
5,817 Posts
Be sure that your VAG cable did upgraded when you loaded new 5.10. It should be done automaticaly. Also double check your CAN wires and K-Line connections.

It takes time (few tries) to connect to #77,
I have the same setup and my coding is in my SIG

|
|
v
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #3
VAG-COM port test says it's version 1.44, K1 OK, K2 OK, CAN not installed (which is OK for a B6). Tried about 20 times now to connect, no success. :?:
 

·
Registered
Joined
·
198 Posts
I couldn't talk to the phone module until the K line was connected.

After that, before it was coded it took many attempts to connect.

At one point I ended up shutting off the car for 10 minutes and then attempted again. (That worked)
 

·
Registered
Joined
·
5,817 Posts
You can stop by at my place if you need any help. I will be running some tests anyway with RNS-E High unit ;)
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #6
Thanks for the offer Proxus, I may actually take it soon before I go crazy.

So, after changing the k-wire (taken from the radio) to the L-wire (taken from the OBD plug) I got connected to #77 and set the following coding:
[siteimg:b002a98f22]366[/siteimg:b002a98f22]

My RNS-E see the phone interface but it doesn't show up in the BT neighborhood of my Treo 650 (nor can my X40 see it).
[siteimg:b002a98f22]364[/siteimg:b002a98f22]
Yes, BT is enabled on my 650 and my X40 can see the Treo but neither of both can the the Audi phone interface. And yes, channel 133 is set to 1 which I thought would enable BT.

On the other hand does my RNS-E show a nice "Change Bluetooth Pin" menu which is actually accessible:
[siteimg:b002a98f22]365[/siteimg:b002a98f22]

Again the question, what am I doing wrong? :cry:

Thanks,
Dirk
 

·
Registered
Joined
·
5,817 Posts
What is your RNS-E coding? 1, 6 or 7? I got mine on 6 and it's working fine.
Can you see TEL interface on your phone Bluetoth menu?

Various phone brands use different Bluetooth protocols. From what I see, the simplier phone that better. I suspect that could be something on the phone side. To be sure I would check it with any confirmed working phone.
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #8
RNS-E "E" is coded to 6, phone is a Treo 650 which doesn't see the RNS-E but see the BT headset I also have. I will keep trying...
 

·
Registered
Joined
·
198 Posts
Did you double check your adaptation coding?

-> Channel 133 (BT)
BT activate/deactivate.

-> Channel 134 (handsfree)
0 - handsfree over BT
1 - handsfree only with mobile in cradle

What firmware are you using with your Treo 650?

Mine doesn't have Bluetooth Neighborhood. I just go in under Blueooth and click Setup devices. Then click on Hands-free Setup. It does a scan and finds the Audi UHV 8184.
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #10
Treo firmware is 1.31 with software 1.15-CNB, double checked the phone interface to make sure that BT and handsfree over BT are enabled. On the Treo it finds the Treo headset but it cannot find the Audi interface - grrr...
 

·
Registered
Joined
·
5,817 Posts
That is a problem right there, because to pair those 2, it will be just enough to power up TEL interface, even if rest of the cables are not connected.

Just in case you can check connection of Bluetooth antenna.
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #12
In case you understood that I tired to pair Treo headset AND Audi interface, no, I powered off the Treo head set before I tried to pair with the Audi interface. Anyway, I'm done for today, maybe I continue next weekend - or just by a B7 which has everything installed :?
 

·
Registered
Joined
·
5,817 Posts
It's not easy :lol: tell me about it....
...I bought a newphone just because of that :evil:

Ask anyone from your office tomorrow with V3 or any other phone from the list to try to connect. I suspect it's the phone because pairing doesn't work and you can connect to the TEL interface so connection between RNS-E and TEL interface should be OK.
 

·
Registered
Joined
·
98 Posts
I'm not sure if this helps, but I had an new A6 loaner while my '04 A4 was in the shop. It had BT, so I thought I'd play with it. My Treo 650 connected to it without a problem, however, it did not load my phonebook. It did however, retain incoming and outgoing phone numbers.

Good luck getting it to work.
 

·
Registered
Joined
·
6,767 Posts
Discussion Starter #15
I made a new attempt getting this to work and completely started over. Maybe someone how has done the conversion can follow the steps and tell me what I'm doing wrong.

I built my own harness starting with 12V+ on pin 54/1 and GND on pin 54/2 (the 54 pin plug is the one at the phone interface). CAN High I connected to pin 54/17, CAN Low to 54/18 - both taken from the Infotainment CAN at the RNS-E. After doing so the RNS-E sees the phone interface when connected and display a message "phone interface not connected" when it isn't.

After my initial issues trying to access the phone interface with my VAG-COM I did figured that the wiring plan shows the phone interface being connected to the K-line but the radio is usually connected to the L-line (or 2nd K-line in newer cars like the B6). The K-line (or K1) is connected to pin 16/7 in the diagnostics (OBD) plug while the L-line is at pin 16/15.

After connecting the radio to pin 16/15 and the phone interface to 16/7 I got connected and configured my phone interface to 0010777. I was surprised to see that after the initial programming the phone interface was responding even when connected to the L-line (together with the radio/RNS-E).

Checking the phone interface fault codes I got only one, for the missing microphone. After connecting the microphone even this error went away and I assume that the working is correct now.

Anyway, I still cannot connect with BT to the phone interface - or even see it. I go my Treo 650, a Sony Ericson T610 and my IBM X40, each with BT and each seeing each other fine. But none of them sees the Audi BT.

I triple checked the coding and #77 channel 133 is set to 1 (BT on), channel 134 is set to 0 (BT without cradle). When I turn the RNS-E on is show "Please wait..." when I press the TEL button but then "Your telephone may not be connected or attached properly."

I even went back, loaded the Euro 0360 software and coded my RNS-E to xxx7x, no change. Proxus, I guess I take your offer and meet you to see what I'm doing wrong. Unless someone else has any idea what's going on.
 
1 - 15 of 15 Posts
Top