Audi Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi I have just retrofitted a MY2010 S4 with a 3G+ MMI Unit. - Screen, headunit, auto hvac, control unit, gateway and, trunk receiver using a Kufatek Harness. I had component protection removed at the dealership. Have been enjoying it for roughly 6 weeks now but.

I have a few questions I was hoping someone could shed some light on.

1st of all. My unit came from a 2013 A4 - its a 3G+ unit confirmed by software version (HN+_US_AU3G_p0609)... yet I have no sim card slot. Does this have anything to do with it being a Canadian version? I don't think I have google maps either yet it shows settings for it in the green menu. If I update firmware / map versions will I get google maps or do I have some strange version of the 3g+

2nd of which is that it seems VCDS has some issues communicating with the new components. There is no information regarding the 'long coding helper' for the auto/hvac unit, the radio or the can gateway. There is a long coding helper for 5F though. Any fix for this or way to figure out what each option is?

3rd is that I had component protection removed at the dealership yet the code still shows in the modules. I am currently having an issue where the radio (fm/am/siruis) work for two seconds and then cut out for two seconds- you can count in your head it's really frustrating. When I say they work I mean the volume works. The channels dont grey out. the volume doesnt say unavailable it simply goes silent for 2 seconds. I was messing around with some settings in the green menu regarding tmc, wlan and googleearth but I dont think this is related- however I wouldn't be surprised.


My Codes are as follows:

Address 19: CAN Gateway Labels: 8T0-907-468.clb
Control Module Part Number: 8R0 907 468 P HW: 8R0 907 468 D
Component and/or Version: GW-BEM 5CAN-M H11 0055
Software Coding: 00C303FF00
4 Faults Found:
01324 - Control Module for All Wheel Drive (J492)
004 - No Signal/Communication
01044 - Control Module Incorrectly Coded
000 - -
02095 - Component Protection Active
000 - -
03041 - Energy Management Active
000 - - - Intermittent

Address 08: Auto HVAC Labels: Redir Fail!
Control Module Part Number: 8K1 820 043 T HW: 8K1 820 043 T
Software Coding: 6490208000

2 Faults Found:
03812 - Relay for Coolant Pump and Auxiliary Air Heater
004 - No Signal/Communication
00457 - Control Module for Network (J519)
004 - No Signal/Communication

Address 56: Radio Labels: Redir Fail!
Control Module Part Number: 4G0 035 082 E HW: 4G0 035 082
Component and/or Version: Radio U SIRIU H60 0121
Software Coding: 020007020000000001

4 Faults Found:
03175 - Invalid Data Set
011 - Open Circuit
03175 - Invalid Data Set
011 - Open Circuit
(i have 2 speakers disconnected)
02095 - Component Protection Active
000 - -
03175 - Invalid Data Set
000 - -

Things to note - AWD module reset basic settings by accident - separate issue, energy management from messing in ACC. Also when I swapped in new components sound quality increased - not sure my speakers could keep up as 2 of them blew and I disconnected them till I get new ones (dash center and passenger front) - Open Circuit. - interesting that it just says invalid dataset instead of a more specific code.

Any input is greatly appreciated. Thanks in advance!

Best,
SC
 

·
Registered
Joined
·
92 Posts
As it stands, your component protection has not been completely deactivated. That's why your radio plays music only for 2 seconds. This can only teach your dealer again online.
Then you should re-code your Unit 19 again. You're doing about the function of the assembly list. The existing coding is correct. The last two bytes are not interesting for you.

The error in the radio with invalid record is also okay, since it has not been adapted to your car.

To the MMI: What exactly is your problem? Google Earth only works with SIM card. Sionst you can not make an online connection

It is important that you have the component protection removed.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thank you very much for your response. I was hoping this wasnt the case. Have you any experience with removing component protection via odis - e? I fear my dealership to be too incompetent to complete the service.

When you mention to recode can gateway 19. I have already corrected the installation list with the components installed in my vehicle. There is no info in the long coding helper. I am not familiar with the function of the last two bytes. By ' not interesting' to me do you mean incorrect or irrelevant? (assuming translated)

From what i understand the component protection needs to be removed from each module then it needs to be adapted to the vehicle? Perhaps they did not do the adaptation process correctly or at all. Which is why I have no label file and get redir! Fail!

The mmi unit i have has the pink connector for the GSM antenna but no Sim card slot. I have read of people using the USB Ami to a wifi adapter to the cell phone as a hotspot.

Best
Sc
 

·
Registered
Joined
·
92 Posts
Component protection can be removed by any dealer. There is the possibility that you select each component itself and this unlocks or you go through the gateway. Then all components are taught to the car. ODIS-E has no function for an official activation via the Audi server in Ingolstadt.

The gateway 19 is coded only via the installation list of the vehicle. The displayed code 00C303FF00 is not this, which is encoded via the installation list. This is about the energy management. The FF and 00 are really uninteresting for your vehicle because it's about gear ratios.

There are parameter sets for The MMI, Radio and the Gateway. These should be recorded so that everything works properly. Unfortunately, the dealer can not. You have to find a professional who can do that.

Give me please the part number of your MMI.
If you need a new MMI with SIM Card, i have it. In which country are you at home?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5 (Edited)
Thank you again for your response and knowledge.
I will make appointment at my dealership then.

On my old 19 gateway the coding was 00C303
My Car is Manual. Car that gateway came from was DSG.

Main unit Part number is 8R1 035 664 C. At home in Canada.
My apologies, i looked again and there is no pink antenna. - I must be confused.
 

·
Registered
Joined
·
92 Posts
Sorry for my late response, I was busy ...my work.
Can you send me please complete scan from your car? I need it, then i am confused with your post/scan.

Okay, your MMI unit is WITHOUT telefon - the partnumber give me this information.
I think, your coding is not correct - i need your scan. Than i can give you the right coding from 19.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Link to full scan here
https://docs.google.com/document/d/1dJ0pmFH1TyorwHZTJbYQ3W_HeHpifQxb2M33PSNkPjs/edit?usp=sharing


installation list below.

Saturday,03,March,2018,15:00:41:15989
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
VCDS Version: 18.2.0.3 (x64) HEX-V2 CB: 0.4411.4
Data version: 20180212 DS287.0
www.Ross-Tech.com


VIN: WAUDGCFL1AA0xxxxx License Plate:


Gateway Installation List: 8R0 907 468 P

01-Engine -- Status: OK 0000
03-ABS Brakes -- Status: Malfunction 0010
04-Steering Angle -- Status: OK 0000
05-Acc/Start Auth. -- Status: OK 0000
08-Auto HVAC -- Status: Malfunction 0010
09-Cent. Elect. -- Status: OK 0000
15-Airbags -- Status: OK 0000
16-Steering wheel -- Status: OK 0000
17-Instruments -- Status: Malfunction 0010
19-CAN Gateway -- Status: Malfunction 0010
22-AWD -- Status: Cannot be reached 1100
36-Seat Mem. Drvr -- Status: Malfunction 0010
42-Door Elect, Driver -- Status: OK 0000
46-Central Conv. -- Status: Malfunction 0010
52-Door Elect, Pass. -- Status: Malfunction 0010
53-Parking Brake -- Status: OK 0000
55-Headlight Range -- Status: Not registered 0001
56-Radio -- Status: Not registered 0011
5F-Information Electr. -- Status: Malfunction 0010
62-Door, Rear Left -- Status: Malfunction 0010
72-Door, Rear Right -- Status: OK 0000
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
This has been solved. The Radio and Headlight range needed to be registered to the can gateway and CP was active on the seat memory module? It took visiting two seperate dealerships but it has been rectified.

For reference here is my installation list after their service

Wednesday,07,March,2018,11:56:30:15989
VCDS -- Windows Based VAG/VAS Emulator Running on Windows 10 x64
VCDS Version: 18.2.0.3 (x64) HEX-V2 CB: 0.4411.4
Data version: 20180212 DS287.0
www.Ross-Tech.com


VIN: WAUDGCFL1AA0xxxxxxx:


Gateway Installation List: 8R0 907 468 P

01-Engine -- Status: OK 0000
03-ABS Brakes -- Status: OK 0000
04-Steering Angle -- Status: OK 0000
05-Acc/Start Auth. -- Status: OK 0000
08-Auto HVAC -- Status: Malfunction 0010
09-Cent. Elect. -- Status: OK 0000
15-Airbags -- Status: OK 0000
16-Steering wheel -- Status: OK 0000
17-Instruments -- Status: Malfunction 0010
19-CAN Gateway -- Status: Malfunction 0010
22-AWD -- Status: Cannot be reached 1100
36-Seat Mem. Drvr -- Status: OK 0000
42-Door Elect, Driver -- Status: OK 0000
46-Central Conv. -- Status: OK 0000
52-Door Elect, Pass. -- Status: OK 0000
53-Parking Brake -- Status: OK 0000
55-Headlight Range -- Status: OK 0000
56-Radio -- Status: OK 0000
5F-Information Electr. -- Status: Malfunction 0010
62-Door, Rear Left -- Status: OK 0000
72-Door, Rear Right -- Status: OK 0000
 

·
Registered
Joined
·
92 Posts
Sorry, I was working for 2 weeks in Turkey. I deliberately did not use the internet.
Okay, what has been solved? In any case, I do not see any major changes to the other scan with RossTech.
Can you please send me a current scan again? I have a S4 MJ 2008 with MMI 2G completely and error-free on MMi 3GP rebuilt. That's why I'm a bit surprised ...
 
1 - 9 of 9 Posts
Top