Audi Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter · #1 ·
Guys.

very strange issue this morning.
A customer bought a new car (A6 Allroad with Telematics etc).
The steering wheel has 6 buttons. The buttons are not only for radio use, but also for telephone etc.

I connected the Canbus wires to the Navigation System (Grey connector / pin 5/6). Everything works fine (illumination, DIS etc) EXCEPT the steering wheel buttons.

I tried to VAG-COm the Steering Wheel module, but that didn't work out.
I also changed the values in the Nav system..

Does anyone have a clue why the steering wheel buttons don't work ?

Thanks,
Tony
 

·
Registered
Joined
·
6,767 Posts
What model year is the Allroad?
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #3 ·
Hi Dirk,

it's a 2003 Allroad.
The bottom buttons are for telephone use. The other 4 are for radio use.
(Volume and track selection).

Regards,
Tony
 

·
Registered
Joined
·
517 Posts
I thought a 2003 a6/Allroad already had CAN wiring in the radio connector. What radio did the car have before and were there any wires present in the grey connector pins 5/6 before you re-wired?

And as Dirk mentioned, the reveision letter of the MFSW controller is important. It has to be at least F to be CAN enabled.
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #6 ·
Thanks for the replies.

It's a -H- revision.
So i'm pretty sure it is can-enabled.

The previous system was an older RNS-D navigation system. Since this system works with the older 'Bosch' can bus system instead of the Entertainment bus I ran a new Can Bus cable directly from the cluster.

Everything works fine. Illumination, Power off shutdown, DIS etc. Except the steering wheel controls..
 

·
Registered
Joined
·
6,767 Posts
You may have accidentally disconnected or interupted the other CAN devices that are connected to the cluster directly. If you removed the RNS-D it would have been better to just bridge the CAN wires at the TMC interface to avoid issues with other devices connected to the same CAN.

Did you check if there are any faults logged in the steering wheel control module that would indicate that it got disconnected from the CAN?
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #8 ·
The buttons work.
They control the Telematics (which still works)

So I guess, it is still connected to the CAN.
 

·
Registered
Joined
·
6,767 Posts
Don't know if that's the issue here but the European Telematics is not working together with the RNS-E. If both are installed then there might be significant issues with the CAN connected devices, up to the CAN completly crashing. The advise given on some boards in Germany is to remove Telematics before installing the RNS-E.
 
1 - 9 of 9 Posts
Top